Error 500 - Twitter app for social login


#1

Hello - I’ve created my Twitter Social Login app, have embedded the

Twitter API Key and Twitter API Secret keys into My Wordpress admin screens, but when I try to login via Twitter social login button it says :-

Server error

500

Details state :-1:
The website encountered an error while retrieving http://www.finditswapit.com/?SuperSocializerAuth=Twitter&super_socializer_redirect_to=http%3A%2F%2Fwww.finditswapit.com%2F. It may be down for maintenance or configured incorrectly.

Any ideas please?

Thanks
webdev71


#2

I’m not familiar with the Super Socializer plugin that you’re using. Twitter’s own Wordpress plugin is documented on our developer site. You may need to ask the developer of the plugin that you’re using for additional assistance, as that error message doesn’t seem like something coming from Twitter.


#3

Looking at the Super Socializer documentation, there’s a chance you’ve specified the callback URL incorrectly in your Twitter app settings (it specifies no trailing slash) - again you should check with the developer for more help.


#4

Andy - I just wanted to say a big thanks for replying so quickly. It wasn’t trailing slashes or anything. I checked the apache2 error.log which said :-

[Tue Feb 02 15:02:20.452233 2016] [:error] [pid 29701] [client xx.xx.xx.xx:63920] PHP Fatal error: Call to undefined function curl_init() in /var/www/website/public_html/wp-content/plugins/super-socializer/library/twitteroauth.php on line 195, referer: http://website.com/wp-login.php

so I installed curl and restarted apache2 :-

root@server:~# sudo apt-get install php5-curl
root@server:~# sudo service apache2 restart

  • Restarting web server apache2 [ OK ]

That did the trick !!

Thanks so much
Russ

P.S. Now getting some other errors - but hey, I’ll get around to looking into that - but at least Twitter works !!! It’s all an uphill struggle

[Tue Feb 02 20:10:06.406627 2016] [:error] [pid 8230] [client xx.xx.xx.xx:55971] PHP Fatal error: Cannot redeclare autolink() (previously declared in /var/www/website/public_html/wp-content/plugins/userpro-messaging/lib/autolink.php:13) in /var/www/website/public_html/cometchat/cometchat_shared.php on line 144, referer: http://www.website.com/


#5

OK this is great news that you’re (partly!) up-and-running! enjoy.


#6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.