Error 112 - You must specify either a list ID or a slug and owner

error-codes
api

#1

Hi,
I’m building a Twitter app and suddenly two Twitter Lists operations stopped working. I’m using TwitterApiExchange by http://github.com/j7mbo/twitter-api-php but this is definitely not an issue with the wrapper because my app uses several dozen operations and everything else is working perfectly fine.

These are the two operations I’m having problem with:
POST lists/members/destroy
POST lists/members/create_all

I’m getting this error:

Array    (
            [0] => Array
                (
                    [code] => 112
                    [message] => You must specify either a list ID or a slug and owner.
                )
        ) 

Of course, I’ve checked and double-checked that I’m giving it all three variables. I’ve also tried it with both numerical ids and slugs - it isn’t making any difference.

Developers have reported similar errors before but there hasn’t been offered a solution. Could you please help?


https://twittercommunity.com/t/post-lists-members-create-all/9223?source_topic_id=53007


#2

Don’t supply 3 variables if using the list_id: Supply list_id with a user_id array of the accounts you’re adding to a list
Or,
If you don’t have a list id, you have to identify the list with a “slug” and the owner screen name or owner id.

Just be careful not to confuse owner_screen_name with screen_name parameters.

Also, in the second thread you link: https://twittercommunity.com/t/post-lists-members-create-all/9223 the call is setting the wrong parameter name: array of user ids sent to POST lists/members/create_all should be user_id not userid https://dev.twitter.com/rest/reference/post/lists/members/create_all


#3

Hi IgorBrigadir,

Thank you for your response. I have tried all possible combinations with ids and slugs. Another clue which says it’s not my error is that I’m now getting two different error codes randomly. It’s either 112 or 25.

[code] => 112 [message] => You must specify either a list ID or a slug and owner. )
[code] => 25 [message] => Query parameters are missing. )

Just to double-check again, I reshuffled the API call to exactly what you suggested - using just the list_id and user_id. I’m getting the same errors.

Also, this worked a few months ago. In the meantime I was developing other functions and now when I came back to the Lists, I found that it has stopped working.

I can also see that this has now stopped working:
POST lists/members/create

List operations that are using GET, for example:
GET lists/list.json
are all working fine.

Other POST operations (the ones that are not related to lists) such as POST statuses/update are working fine.

Is it possible to check this on Twitter side? Otherwise it’s almost like I’ve wasted 2+ years of my life as I’ve been working on this full-time :anguished:

Thanks


#4

Strange - I didn’t try the PHP library, but the CURL command from OAuth Signature Generator https://dev.twitter.com/rest/reference/post/lists/members/create_all works for me

(Excluding OAuth parts, the list ID is one of my own)

curl --request 'POST' 'https://api.twitter.com/1.1/lists/members/create_all.json' --data 'list_id=221404313&user_id=38895958%2C14927800%2C7588892%2C819797%2C795649%2C657693'

Maybe there’s a problem with how the library is encoding the POST parameters? That’s the only thing I can think of.


#5

@IgorBrigadir, thank you for your help. It’s something to do with the library at https://github.com/J7mbo/twitter-api-php - I didn’t figure out exactly what it was but I have switched the faulty operations to this library https://github.com/ricardoper/TwitterOAuth and it is now working fine. I’ve notified the developer of the faulty library.