Empty result with query "from:user" for a specific user

search
api
premium

#1

I am using the Full Archive Premium Search API with the Python library searchtweets.

When I request Tweets of my own account with “from:luca” I get results as expected, but when I use “from:hsnfrhanalmalki” I don’t get any results. But there should be nearly 100k Tweets: https://twitter.com/search?f=tweets&vertical=default&q=from%3AHsnFrhanALmalki&src=typd

This is my current code:

rule = gen_rule_payload("from:hsnfrhanalmalki", 
                        results_per_call=500)
rs = ResultStream(rule_payload=rule,
                  from_date="2011-01-01",
                  to_date="2017-09-10",
                  max_results=1000,
                  max_pages=2,
                  **premium_search_args)

I tried to replace the username with the numeric ID and all lowercase. Because the last Tweet was published about a year ago I tried to use a specific time frame:

                  from_date="2011-01-01",
                  to_date="2017-09-10",

The results are always empty.

I found the thread about some users not showing up in the normale search, but this shouldn’t be the issue. The query works with the web interface and the Full Archive shouldn’t be affected by such filtering.

Thank you for any hints and help.


#2

All signs point to this individual having set their account to private at the time that they were posting the Tweets. We do not surface Tweets that were posted when the user was private via the APIs.


#3

I didn’t know that. Thanks.

I find it unlikely that the account posted 90k Tweets, gained 300k Followers and got verified while being private. Most of his Tweets got retweeted 10-100 times. This wouldn’t be possible if the accounts was private. There is the small possibility that the retweeting happend after the account went public.

I just asked a contact if the account ever was private and will add the info, once I have it.


#5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.