Embedded Twitter timeline is not working?

embeddedtimeline

#1

I’m new to this, working on my personal blog and thought I’d include an embedded side bar with my twitter time line in it. A quick search threw up the results I wanted [1]. I went through the process which lead me to [2] and the process on that page which gave me a html anchor element, like [3].

So that seems to be the process, which I’ve obviously misunderstood and got horribly wrong. [3] is a html anchor and following the link does take me to twitter but it’s a bit of a stretch to call it “embedded”. Maybe I’ve totally misunderstood?

[1] https://dev.twitter.com/web/embedded-timelines
[2] https://publish.twitter.com/#
[3] Tweets by TwitterDev


#2

Hi John, make sure that the HTML link you’re pasting in includes the <script> tag next to it, which will do the magic to initialize the widget from the link.

If your CMS or other tooling is stripping out the script, then add the following to your template, and it should do the work:

<script src="https://platform.twitter.com/widgets.js" async></script>

Ben


#3

Thank you benward missed that part of the process. Sorted!


#4

Hello,

I have inserted the script that is generated from the create a widget section.

Placed it into the webpage and receive the following message.

The script appears to be intact and resembles another that works?


#5

There are no recent Tweets on that hashtag within the past 7 days. The search widget only supports Tweets from a 7 day window.


#6

Thanks Andy,

I will convey that to the people in charge.

Should that not be the issue, I will reach out again.


#7

Hi All

i am also new to this and am working on a Raspberry Pi project to create an info page on a monitor in my hall way. i am trying to embed a twitter feed that gives information regarding traffic in my local area route to work.

i have gone through the process to create the embedded link which is below
a class=“twitter-timeline” data-height=“500” href=“https://twitter.com/HighwaysSEAST”>Tweets by HighwaysSEAST
script async src="//platform.twitter.com/widgets.js" charset=“utf-8”>

i have removed some of the formatting above so that you can see the code
the twitter feed that i want is
https://twitter.com/HighwaysSEAST

i have just put this into a basic HTML file to make sure that i get the outcome that i am looking for. when i am testing this the widget is not showing up all i am getting is

i have read a few other feeds and i have tried to browse to platform.twitter.com
and i get the below

AccessDenied
Access Denied
429AA61DD515C10A

NvIHwWmSkhixH1ea5NaeYO9X8Z0MEYhVcKrC+DPwpEuJBNGjcRIprlghEJ2idfTaP8NGueq9QHQ=

i have confirmed that i am trying to load the twitter java script and is in the code above.
i am using Chrome but i have also tried in Firefox and IE.

any assistance would be much appreciated