Embedded timelines for narrow widgets messed up again


#1

Hi,

this is a bahavior that already occured for a few hours last week as the transparent parameter wasn’t working properly. Since the bug was fixed last week, everything looked fine until it started again some time yesterday. It seems the layout for embedded timelines has drastically changed, which affectes widgets with small widths in particular.

  • text is cropped (no wrapping)
  • images are cropped halfway too
  • two column layout (left for user icon, right for the rest)
  • therefor further indentation/cropping of text/images
  • CSS for text is ignored

I don’t know if this is a bug again or if Twitter is restyling the widgets. That would be bad news for all embedded timelines in sidebars as they become unusable for narrow divs. My div has a width of 264px. It seems the widget simply injects with a width of 520px not respecting the width of the parent div.

Perhaps someone can have a look on this.

Thanks.
Markus

UPDATE: I fixed it by specifing the “width”-parameter in the anchor element. This wasn’t necessary until yesterday. It simply adjusted to the width of the parent div before.

UPDATE 2: On mobile devices scrolling the widget doesn’t work any more. One attribute of the iframe is scrollable=“no”. The attribute “noscrollbar” has no effect on this.


#2

Can you please share a URL which demonstrates this behavior?


#3

www.stamm-bonifatius.de

The funny thing is, if I set the width=“264” attribute in the anchor element the layout of the timeline looks like I am used to. But scrolling on mobile devices doesn’t work.

If I do not set the width-attribute I get a different timeline layout since yesterday. Scrolling on mobile devices (tested with iOS mainly) WORKS this way. The crop issues I mentioned before are mysteriously gone now. So the iframe seems to respect the width of the parent div now. But it is wasted space anyway with the intended text/images.

Here two images for comparsion. First with width-attribute set, second without width-attribute. I would prefer the first way since it integrates much better with the overall layout and doesn’t waste space for the user icons. But then I have the scrolling issue.

width=“264”:

no width-attribute set:

Just checked again, I now have the scrolling issue even on desktop browsers like Chrome or Safari.
It seems like everytime I check, there is something different. :wink:

Thanks in advance.
Markus


#4

I am experiencing problems too on 3 sites. Feed not showing at all.All were fine until recently(?) Al Joomla 2.5


#5

Can you provide links?


#6

@stammbonifatius We deployed a fix that should address the issues. Note, it will take a few hours for the update to roll out through CDNs and proxies. Thanks for the detailed post and I’m really sorry for your troubles.


#7

I’m too having the same problem again: it began last week, went away, then the problem arrived again today or yesterday. I’m having a SharePoint site. Twitter widget webpart broadens the whole layout column now.


#8

Is this still an issue? Is your Sharepoint setting an X-UA-Compatible header which forces browsers to a version of IE we don’t support (version 9+ supported)?


#9

Thanks a lot. It looks like everything’s working as expected again. The width-attribute isn’t necessary any more to get the “old” edge-to-edge layout. Scrolling is working again, too.

If I keep the width-attribute set, the scrolling issue persists. But that won’t bother me since I can remove this attribute now.

Thank you for the quick responses and fixes!
Markus


#10