Embedded Timeline not rendering in Internet Explorer


#1

Today our embedded timeline stopped working in Internet Explorer 11. This is an internal intranet page so i can’t share the url. This is a basic twitter-timeline embed. I don’t see any console errors and the page will work in chrome and firefox. The last request in a fiddler trace is widgets.js in IE and for chrome it proceeds past that request. Any help is appreciated. Thanks.


#2

Hi @joe_reichard,

I’m unable to reproduce this issue. Can you provide the embed code for the timeline? Or possibly test to see if it renders correctly on publish.twitter.com?

Thanks!


#3

I have the exact same issue. We are using IE11 (Document mode 10). Intranet so can’t provide the URL
Embedded timelines were working on Friday but have stopped since then.

  • The widget script was the standard output created using the tool at publish.twitter.com
  • If I switch IE to Document mode 11 then the timelines will load, unfortunately we currently need to remain in Document mode 10.
  • I can also confirm it still works in Chrome and Edge
  • Has anything changed that would prevent the timelines loading in Document mode 10?

#4

Hi @joe_reichard and @Daveyskills1977,

Thanks for the additional info. I was able to reproduce this issue by running IE 11 with “Document Mode” set to IE 10. This essentially causes the browser to act as IE 10.

We recently announced that we won’t be supporting IE 9 and IE 10 anymore, and I believe that change is what is causing widgets not to render on your pages.

To fix this, you can try to load your page without using IE 10 compatibility mode. This could be caused by a browser setting, or by an HTML tag like <meta http-equiv="X-UA-Compatible" content="IE=10" /> on the site you’re visiting.

I hope that helps!


#5

Thanks for the update, I was assuming this was the case.
I understand that SharePoint 2013 is set to use document mode 10 by default so you may see a number of queries along these lines!

Thanks again.


#6

SharePoint 2013 indeed needs the meta http-equiv=“X-UA-Compatible” content=“IE=10” to be set in order to work with Internet Explorer browsers. It’s in the out of the box master pages and removing it breaks core functionality of SharePoint in Internet Explorer. Microsoft says edge mode (the latest) is not support in SharePoint 2013 (see here: https://docs.microsoft.com/en-us/sharepoint/install/browser-support-planning) so the tag has to stay on SharePoint 2013 sites. Does this mean no more embedding Twitter feeds in SharePoint?


#7

Hi,

As stated earlier, SharePoint 2013 indeed contains the meta http-equiv=“X-UA-Compatible” content=“IE=10” within the Master Pages. So it would be unwise to remove the tag from the Master Pages.

Could you please provide a workaround for SP2013 and IE11 as we have a number of embedded feeds on the company Intranet, which have recently stopped working?

Or, do we just reside to the fact that the functionality of embedding Twitter feeds in SP2013 is long gone?

Thanks

Chordster001


#8

We are also having same issue in SharePoint 2013 environment. Do you have any updates on this please?


#10

Thanks for the feedback here. We recognise that this is inconvenient for some users.

We don’t have any plans to build in a workaround for this specific use case - Microsoft announced the end of life for Internet Explorer 9 & 10 as January 2016, and while this incompatibility is unfortunate for this specific case, unfortunately our embedded timelines will no longer work and cannot be used in browsers operating in IE 10 document mode as we invest in ongoing improvements to support modern web standards.

For further information, please refer to Microsoft’s documentation on older versions of Internet Explorer and their lifecycles.