Embedded Code for Timeline Stopped displaying Tweets

embeddedtimeline

#1

I was using an embedded code of a twitter search on my website. It was working fine, however it is now not showing up. I deleted the embedded code & recreated one. When on twitter creating the embedded code the preview says there is an empty timeline for that search. However when I search for that hashtag multiple public tweets appear. How can I fix this?


#2

The embedded search timeline includes recent Tweets, published within the last ~7 days. If the Tweets you see for a search result on Twitter.com were published over 7 days ago then an empty timeline is the expected behavior.


#3

I would like to have it update itself but how previous tweets.Is there a way for all tweets to show up -besides embedding each individual tweet to the website.


#4

The code I embed into my websites in order to get a twitter timeline is not working.
The only thing I see is ’ tweets by "

If i am correct this error lies with twitter and has quite a history in all the topics

When you will resolve this issue ?


#5
            <a class="twitter-timeline"  href="XXXXXX"  data-widget-id="XXXXXXXXXXXXXXXX">Tweets by </a><script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"http://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>

I have already replaced ‘//platform.twitter.com/widgets.js’ it possible that this script ‘widgets.js’ generates an error?


#6

Do you mind sharing the widget id?


#7

Not at all:
663659067018223616

Same issue shows up at other IDs/twitter accounts as well


#8

So if you use the following embed code, the timeline still doesn’t render?

<a class="twitter-timeline" href="https://twitter.com/SamenSlimZorgen" data-widget-id="663659067018223616">Tweets</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>

Just want to confirm some assumptions.


#9

Now it shows:

‘Tweets’

Still no timeline…


#10

I just checked the website in Safari
Now the timeline does render at iPad & iPhone
Also rendering at a desktop in Chrome & IE11!

In Firefox still nothing no timeline


#11

Hmm the most likely issue is there’s other code on the page that’s interfering with widgets.js. Is the web page you’re embedding this timeline on public? If so, can you share a link? I can poke around and see if there’s anything that could cause an issue.


#12

Hmm i am sure that the cause of the problem doesn’t lies in the website or in a conflict with another script to be honest
Because even when i embed the twitter timeline code in a blank html-page without any other javascript (or html/css) in it, the error still remains; the twitter timeline won’t render. In Firefox.

https://twittercommunity.com/t/twitter-widget-not-working-in-firefox/20576/8


#13

Are you using a “Private Browsing” window in Firefox? If so, this is probably the problem: https://developer.mozilla.org/en-US/Firefox/Privacy/Tracking_Protection.

Also, do you see in logs in the console regarding a script from platform.twitter.com?


#14

Yes this was causing the problem… Solved!

Firebox 42 blocks twitters timeline in default mode

Thank you JakeHarding…
All the fancy sheelds should have rung the bell… :wink:


#15