Embed Twitter timeline shows blank empty result page


#1

Hi,

I’m an experencied web developer, and for some reason the embed twitter for one of our clients is not working anymore.

They have 2 accounts for 2 languages and it only works for one of them.

We are worried because we are going to launch a new site to production and we can’t solve this issue.

Here is the code we use to embed twitter and it does not work
<a class="twitter-timeline" href="https://twitter.com/EDUCAMOS_es">Tweets by EDUCAMOS_es</a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>

This is the same code for the other language, and it works perfectly:
<a class="twitter-timeline" href="https://twitter.com/EDUCAMOS_cat">Tweets by EDUCAMOS_cat</a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>

Seriously, I have tried everything, I have searched the web, and this is my last hope in order to solve this.

Best regards,
Felipe.


#2

Hey Felipe - I’ve reproduced this locally but I can’t figure out the issue at the moment - I’ll see if someone else can take a look when they come online later.


#3

We noticed a Periscope posted to the timeline of EDUCAMOS_es renders an empty Tweet on Twitter.com. Deleting this Tweet should fix the display issues.
https://twitter.com/EDUCAMOS_es/status/831444612044709888


#4

Thank you very much, that was the solution, but maybe is better if you fix this issue in the server :slight_smile:

Regards,
Felipe.


#5

Thanks for your patience and understanding Felipe - we are working on a fix, but glad to have help you with a workaround in the meantime!


#6

Hello! I’m new to this site and just learning the basics of web management, coding, etc. so please bear with me. I’m trying to embed my boss’s twitter timeline (@ericacaplejames) into the homepage of our company website (https://ghmhi.mit.edu/welcome). I’ve tried following some of the troubleshooting steps on the Twitter website and posted through this community, but am still coming up short.

I seem to have two main problems. The first is that when I embed the timeline link into our website, it appears as “Tweets about EricaCapleJames” and allows users to click on that link to reroute back to the Twitter feed, rather than populating the recent tweets in a list. This is the embed code I’m using:

<a class="twitter-timeline" href="https://twitter.com/EricaCapleJames">Tweets by EricaCapleJames</a> <script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script>

And the second issue is that when I initially tried to generate the Twitter widget, a message appeared indicating that my boss’s Twitter timeline is blank, although it is not; she has Tweeted most recently on 2/22, 2/20, 2/3, etc.

Any assistance that this group can offer is greatly appreciated! Thank you!!!


#7

Two things to check:

  1. Do you have any ad or other blockers that might be stopping Twitter’s Javascript from loading?
  2. Could you try adding “https:” to the <script> tag e.g. <script async src="https://platform...

I just tried generating a timeline via publish.twitter.com for that user’s profile and it seems to show up fine.


#8

Hi Andy,

Thanks so much for your reply! We don’t have any ads on our website so I’m assuming there is nothing blocking the timeline, but it’s possible. Is there an easy way to check on that? And I just added https:// within the script tag as you suggest but that didn’t seem to help. Please let me know if you can think of any other adjustments that I might be able to make.

Thank you!

Brittany


#9

I was talking about ad blockers in your browser rather than on your site. What browser are you using?


#10

Oh sorry I misunderstood! I’m using Firefox.


#11

Hi Andy,

I hope this message finds you well! I just wanted to circle back to let you know my problem has been resolved! I was playing around online trying to troubleshoot the issue and I came across a discussion in the Twitter Community from December 2015 (Twitter Timeline widget not working). The problem was on my end - Firefox was displaying a shield icon that I hadn’t even noticed before, thus blocking the timeline feed from populating. So we are now back up and running (https://ghmhi.mit.edu/ - see bottom right of homepage). Thanks for your assistance the other day!


#13

I’m having this same problem on my site: www.CallMyLostPhone.com


#14

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.