Embed timeline only shows link - no actual tweets


#1

Hi. I’m trying to embed a timeline into my website. I created a new widget and it gave me this code:

<a class="twitter-timeline" data-width="220" data-height="230" href="https://twitter.com/fabric">Tweets</a> <script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script>

I have adblocker turned off. Using Chrome and Dreamweaver. Am I supposed to do something else somewhere? It’s not mentioned when you grab the code. I’ve been all over the web trying to find a straight answer but can’t find what will make it work. My website isn’t live yet.

Thanks for any help!


#2

Sorry, it converted my code to an actual link. How can I show the code without it doing that?


#3

(Edited)


#4

The widget generator outputs HTML to include in your webpage. If you are using a graphical editor look for a “raw” edit mode to insert raw HTML or a HTML module you can drop onto your page to insert exact HTML.


#5

Thanks for your response, Niall. I use the code view in dreamweaver. I inserted the html code from the widget generator. It doesn’t show my twitter feed, but just a link to it.


#6

A Twitter widget consists of two parts: the link on the page with the proper class applied and Twitter’s widgets JavaScript to turn the link into a full widget display.

If you view source of the page output do you see platform.twitter.com/widgets.js as expected? If not it’s possible the <script> component of the pasted markup is stripped by Dreamweaver.

If you see the JavaScript output in the page try viewing the generated page in a different browser to eliminate the possibility your browser or its installed plugins/extensions have altered output.


#7

Hi Niall, no I don’t see all the platform code output with my code. I just see my template code with the widget code I pasted in there. I’ll try it on a couple of different pc’s with different browsers as you suggest. Thank you!


#8

Hello Nula, I had a similar problem myself. The problem is that the code they give offers an incomplete link the the java script. Make sure there is an “https:” in front of the “//platform.twitter.com/widgets.js” once I put that in it worked just fine for me.


#9

Hey Biblio! Right on! That was exactly the problem. My widget code was not preceded by the https:. I added it and now it all works just fine. Thank you very much! Thank you guys for your quick responses - it is much appreciated!


#10

Hi, I have this exact problem too, since the big twitter embedded code upgrade my embedded timeline has stopped working.

I added the https: exactly like you say but still no luck :frowning:

any further ideas? the widget created twitter supply makes html which literally just shows a link to the timeline.


#11

In retrospect, of course their code wasn’t going to work. You’ve double-checked your code, right? Does the problem persist over different browsers for you? I hope they fix the error in the code.
https://platform.twitter.com/widgets.js


#12

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.