Embed Timeline on Website


#1

I’ve used the publish.twitter.com website to create the code to embed our Twitter timeline on our website. On publish.twitter.com it displays. When I copy the HTML and Javascript to our website, the only thing it displays is an HTML link as a basic text link. Our timeline isn’t displayed at all. The code seems fairly simple to add, so I can’t imagine I’m doing something wrong. Any ideas?

Thanks,
Nick


#2

Hi @KeigerInc,

It’s likely the javascript is blocked on your page. Can you provide a link to the page where this is happening?

Thanks!


#3

I use javascript all over the site, so I doubt that’s it. However, our site is www.keiger.com. I’ve removed the embed code right now so customers don’t see something incorrect. I tried the code on the sidebar, which shows up on every page. I also tried it on our social and news pages. Here’s the links to those addresses.

www.keiger.com/Pages/Social.asp
www.keiger.com/Pages/News.asp


#4

I won’t be able to reproduce and investigate the issue if you can’t provide a link to an example that isn’t working. Is it possible to add a test page with an example of the issue?


#5

Here’s a test page I set-up.

http://www.keiger.com


#6

Any luck reproducing or finding a solution?

Thanks!


#7

I found the issue. It was tracking protection in Firefox. I wasn’t in a private window, but tracking protection was always on. Do you know of any way to get around this? It blocks https://platform.twitter.com/widgets.js. You were right about it blocking javascript. However, it wasn’t the site, it was the browser.


#8

Glad you were able to figure this out!


#9

Any idea how to keep things like tracking protection, Ad blockers, etc. from blocking the Twitter widget. If this is the new way to display Twitter, I would think they would have taken these now normal elements into account. Browsers are automatically blocking more with every version that comes out. The Twitter widget will be useless soon if there isn’t a workaround.


#10

Hi @KeigerInc,

Can you share more about your setup so we can look into this further? (Browser Version, OS, Installed Extensions, etc.)

Also feel free to reach out to Firefox support and let them know this is an issue for you. It’s always good to have users report issues directly to them.

Thanks!


#11

We use Firefox and I’ve got it loaded on Windows XP using Firefox 52 ESR 32-bit up to Windows 10 using Firefox 59 64-bit. Add-ons are irrelevant, I can do a fresh install with nothing but the browser and have this issue. In Firefox’s case it specifically lies in their Tracking Protection setting or Private Mode. I’ve also heard that Chrome and other browsers are cracking down on similar types of issues. This makes me wonder if the Twitter widget is even going to be usable in 6 months to a year as fast as browsers are iterating these days. I’d have to do more testing on other browsers to know what doesn’t work and what’s causing it. As well as other OSs since we also use Macs. I don’t have time to do that much testing right now. I listen to plenty of tech podcasts and they’ve been saying stuff like this was going to be an issue for the last couple of years. I would think Twitter would have planned for it.


#12

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.