Email not being returned from verify_credentials (Yes, we're whitelisted)

oauth
rest
whitelisting
email

#1

We have been whitelisted for requesting email from users, we’ve enabled the ‘request email’ permission for the app, and we’re making the request properly, according to the documentation: https://api.twitter.com/1.1/account/verify_credentials.json?skip_status=1&include_email=1

The issue is that the email isn’t being returned, even though the permission is granted (and visible in the Settings/Apps list). I’ve tried with existing accounts, and with a brand new account (after verifying the email), as seen here;

This is the entirety of what’s being returned by verify_credentials:

array (
  'id' => 710562945793527808,
  'id_str' => '710562945793527808',
  'name' => 'Kat Emailtest',
  'screen_name' => 'KatEmailTest001',
  'location' => '',
  'description' => '',
  'url' => NULL,
  'entities' =>
  array (
    'description' =>
    array (
      'urls' =>
      array (
      ),
    ),
  ),
  'protected' => false,
  'followers_count' => 0,
  'friends_count' => 0,
  'listed_count' => 0,
  'created_at' => 'Thu Mar 17 20:26:22 +0000 2016',
  'favourites_count' => 0,
  'utc_offset' => NULL,
  'time_zone' => NULL,
  'geo_enabled' => false,
  'verified' => false,
  'statuses_count' => 0,
  'lang' => 'en',
  'contributors_enabled' => false,
  'is_translator' => false,
  'is_translation_enabled' => false,
  'profile_background_color' => 'F5F8FA',
  'profile_background_image_url' => NULL,
  'profile_background_image_url_https' => NULL,
  'profile_background_tile' => false,
  'profile_image_url' => 'http://abs.twimg.com/sticky/default_profile_images/default_profile_2_normal.png',
  'profile_image_url_https' => 'https://abs.twimg.com/sticky/default_profile_images/default_profile_2_normal.png',
  'profile_link_color' => '2B7BB9',
  'profile_sidebar_border_color' => 'C0DEED',
  'profile_sidebar_fill_color' => 'DDEEF6',
  'profile_text_color' => '333333',
  'profile_use_background_image' => true,
  'has_extended_profile' => false,
  'default_profile' => true,
  'default_profile_image' => true,
  'following' => false,
  'follow_request_sent' => false,
  'notifications' => false,
)

At this point, I don’t even know what the field is supposed to be named… is it just ‘email’?


#2

Does it work if you try with include_email=true (encode parameters as a string as opposed to =1 boolean)


#3

Holy shit.

Yes - that does it. I didn’t even think about that because I’ve never seen another parameter that was that pedantic. They all accept 1/“t”/“true”.

Thanks.


#4