Duplicate Twitter card tags in source code


#1

I set up a plug in on my Wordpress website to allow me to use summary below large image Twitter cards, however posts come up as summary cards every time. In the source code the plug in meta is there, but then further down you find the code for the summary card. I know I just need to delete that second tag, but I can’t find it. I have searched through what I believe is every bit of code I can to try to find where the twitter:card content=summary code is, but I can’t find it anywhere. Any help would be greatly appreciated.


Using the Eleven40 theme with Genesis Framework


#2

The tag I need to delete is on line 92 when you pull up the source code in Google Chrome


#3

This makes it sounds like you have more than one plugin that is injecting the code. Very sorry but it is super difficult for us to support ever CMS / blogging system and scenario here. I’d look into what plugins you’ve installed and enabled.


#4

That was my original thought, so I went through the plug ins. I disabled them one at a time, but that code never disappeared, which made me think it may be elsewhere. I do have the Twitter and Custom Twitter Feed plug in installed, but those were the first ones I disabled. If it was in the plug in and I disabled it, it would change the source code immediately correct? It wouldn’t be cached for a specific amount of time?


#5

Honestly since I do not run a local Wordpress site myself I could not say. Apologies.


#6

Looks like one is provided by JM Twitter Cards. Do you also have the official Twitter Wordpress plugin installed?


#7

Yes, I do have the official Twitter plug in installed. The JM Cards plug in is the one I installed specifically for the cards. I did that because there wasn’t an option in the Twitter plug in for the cards.


#8

The Twitter Wordpress plugin adds summary cards automatically. You only need one of these. If this is not clear in our documentation I will make a note to update it.


#9

Ya, I didn’t notice that, but I really was focusing on the settings inside Wordpress rather than reading all of the documentation. That should fix it then. However, I disabled that previously but it didn’t fix the problem. I don’t know if it may just take a little time for the change to take place. Either way, that is probably the source. Thank you for your help.


#10

I feel dumb, that took the code away right away. I must not have disabled it properly the first time. However, in the validator and on a timeline it still comes up as a Summary card.


#11

Patience fixed everything. Thank you again for your help, I appreciate it.


#12

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.