Domain whitelisted but image doesn't show

cards

#1

Issue:

Hello,

My domain is whitelisted and I’m sending these meta tags (below) and receiving this response (right after meta tags below) in the card validator but even doing all this, my cards still not rendering the image.

<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="O vestuário é claro: shortinho combinado com body ou cropped e uma sandália Melissa de laço chamativo." />
<meta name="twitter:title" content="Praia dos Crush nunca mais será a mesma depois do... Encontrão das Pirangueiras" />
<meta name="twitter:site" content="@tribunaceara" />
<meta name="twitter:image" content="http://jgdprod-us.s3.amazonaws.com/wp-content/uploads/sites/5/2017/06/praia-dos-crush-560x362.jpg" />
<meta name="twitter:creator" content="@tribunaceara" />

The image is hosted on a AWS S3 bucket that happens to have a block for hotlinks but already whitelisted *twitter.com and *.twimg.com to access the image.

What else can I do?

URL affected: http://tribunadoceara.uol.com.br/diversao/comportamento/praia-dos-crush-nunca-mais-sera-a-mesma-depois-do-encontrao-das-pirangueiras/

Troubleshooting steps tried already:


#2

curl -A Twitterbot http://jgdprod-us.s3.amazonaws.com/wp-content/uploads/sites/5/2017/06/praia-dos-crush-560x362.jpg returns HTTP 403 forbidden, so the image cannot be loaded.


#3

Thank you for the fast reply, Andy!

Is there a way to allow Twitterbot to access the files?
Is there a fixed IP or a hostname to allow it?

Thanks again in advance!


#4

Twitter’s IP range is listed in the Troubleshooting documentation if you want to add specific rules on AWS to allow this.


#5

Thank you, Andy!

Problem solved with Twitter’s IP range!


#6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.