Display of image in Twitter Summary Card


#1

Hi
I have installed JM Twitter cards plugin on my Wordpress web site. Using the Card Validator the default
image set appears OK
When I enter an override image at the foot of a post and check in the Card Validator, the image is not accepted. I get a greyed out square.
Could anyone kindly point out, in layman’s speak, what I need to do to correct this, please. Twitter cards have been validated

Thanks to anyone who replies

Paul Lewis


#2

Please post the URL to a sample post or page here.


#3

Hi

Nice of you to reply, thanks.

sample post http://firsttodraw.com/wp-admin/post.php?post=1114&action=edit
which is
http://firsttodraw.com/do-voiceovers-really-matter-in-a-whiteboard-animation/


#4

I’m seeing the same thing on a site I’m working on. The URL validates fully, but no image is displayed. Have also tested with a tweet and still no image.

Any ideas?


#5

Try adding the image meta tag, for example:

<meta property="og:image" content="http://placehold.it/800x600">

#6

Thanks, jublonet, for your reply. Could I ask you one favor, please. Assume that you are dealing with a total beginner, which you are, not a developer. Could you please indicate where the tag is to go, and which items need substituting with my own characters. Thanks


#7

Hi, Paul!

First of all, it looks like you’re using Wordpress for your site, and you are using 2 plugins - Yoast SEO, and JM Twitter Cards. We don’t officially support either of these ourselves but both work well in my experience. The problem is that you don’t need both of them for Cards to work, and right now they are duplicating the information in your header. To see this, if you view the source of your webpage, inside the <head> section you have two sets of references to twitter:card markup, added once by each of these two plugins. I’d disable one of these, probably JM Twitter Cards since the Yoast plugin offers other features as well.

Now the second issue here. You’re using a Twitter Summary Card, and for that to display an image you need a tag in the same section which either provides twitter:image or og:image and a link to the image. I don’t see that in your page, so either there’s something wrong with your plugin (and you’ll need to check with the author why it isn’t adding the link), or you’re not adding the URL to the image in your configuration correctly.


#8

@we_sort I just tried your page in the validator and it looks like you’re all set now. However, you’re using <meta name="twitter:image" property="og:image" content="http://wildercreative.co.uk/./content/index/thumb.jpg" /> and I’d suggest using just og:image and removing twitter:image since there’s no need to include both values inside the tag.


#9

No images in Summary Card.
Can you suggest a solution? I’m using the following Tags:

<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@nandanoriya" />
<meta name="twitter:title" content="Nandankanan Odia Magazine" />
<meta name="twitter:description" content="ନନ୍ଦନକାନନ ୱେବସାଇଟରେ ପଢନ୍ତୁ ଓ ପଢ଼ାନ୍ତୁ  ପତ୍ରିକା  ଓ ଗପ ବହି I ପଢ଼ ଓଡିଆ । କୁହ ଓଡିଆ । ଲେଖ ଓଡିଆ । .. ଜୟ ଜଗନ୍ନାଥ !" />
<meta name="twitter:image" content="http://nandankanan.tripod.com/2014_puja.jpg"/>