Disable Twitter Universal Deep Links

ios
oauth

#1

I have a UIWebView that opens and directs to Twitters Oauth/Authorize webpage. The user signs in with there Twitter details and authenticates the use of our application with there Twitter account. This process worked perfect before the release of Twitter 6.37 iOS application. What happens now is when the WebView detects https://twitter.com/oauth/authorize?oauth_token instead of staying in the WebView it opens the native Twitter application and dies. If you uninstall the Twitter application everything works as usually it staying within the WebView. How can I prevent this from happening? I want to stay within my UIWebView and not automatically open deep links. I have been reading about the new URL deep link changes in iOS 9, but not sure of how to stop them from my application to other native applications. Thanks for any help!

Question on stack overflow also -> http://stackoverflow.com/questions/32824532/disable-twitter-universal-deep-links


#2

Clicking the go button on the keyboard instead of “Authorize App” in the webview fixes the issue. -http://stackoverflow.com/a/33033836/757503

I hope Twitter fixes this in the future.


#3

We have the same exact problem. Can someone from twitter please chime in as to how this will be addressed?


#4

I ran into this issue as well and figured out it was because my authorize endpoint was set to https://twitter.com/oauth/authorize?oauth_token="+oauthToken (I believe this was in the original documentation). If you add api as the subdomain: https://api.twitter.com/oauth/authorize?oauth_token="+oauthToken , it will no longer trigger the deep linking and load the twitter app.