Dev Guide on Geocode Search has a mistake


#1

This was a problem that took me a while to figure out.

On this page: https://developer.twitter.com/en/docs/tweets/search/guides/standard-operators

It gives an example: " You want: all recent Tweets in Portuguese, near Maracanã soccer stadium in Rio de Janeiro

Your search URL is: https://api.twitter.com/1.1/search/tweets.json?q=geocode=-22.912214,-43.230182,1km&lang=pt&result_type=recent"

However it only works if in the query you do “geocode:-22.912…” instead of “geocode=-22.912…” note the use of : instead of =

I hope this helps out others or they can fix this documentation


#2

Hello @nolanmagee4!

Thank you for your message and for letting us know. Your feedback and experience on our documentation matters, and if there are any errors you come across we appreciate finding out so we can fix them right away.

I’m going to work on resolving this, and if you find anything else, please don’t hesitate to let us know.


#3

@nolanmagee4 - While there is an error in that example, it isn’t because of the ‘:’ symbol, although I am seeing that this does actually yield results.

While we do require the q parameter, you can technically pass along just the q without a value if you have other parameters.

Here is what this URL should be. I will be updating this in our docs today:
https://api.twitter.com/1.1/search/tweets.json?q&geocode=-22.912214,-43.230182,1km&lang=pt&result_type=recent

I suggest that you continue using ‘=’ as much as possible, as that is our best practice.


#4

@nolanmagee : thank you !! I could not get that code fragment to work either.


#5

@bici_sancta - What error message are you receiving? I was able to successfully use that exact call in a request just now.


#6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.