Data-count="none" does not work!


#1

data-count=“none” does not work on my site www.skatar.com, nor the direct url given in my IFRAME-code:

Any ideas why?

I don’t want to see the count…


#2

data-* parameters are not supported as attributes of the iframe button (the iframed content can’t see the DOM of the parent page). You’ll need to pass your parameters via the IFRAME URL, so use src=“http://platform.twitter.com/widgets/tweet_button.html?count=none” as the src property.


#3

great! That works, thank you!

Unfortunately, I have another problem;

I am writing this:

When clicking on the tweet button, I then of course want http://www.skatar.com/index.php?/collaborations/ to appear.

But, instead the twitter window writes my root URL: http://www.skatar.com/

Is that because of my homepage script or can I somehow solve it in another way?

Another question I have is if there is a way to automatically transform long URLs into t.co or bit.ly ?
I mean, the URLs above is too long for tweet I think.

Best regards,
Fredrik


#4

This is the same issue. Data-* parameters will not work on the iframe, so use
http://platform.twitter.com/widgets/tweet_button.html?count=none&url=http%3A%2F%2Fwww.skatar.com%2Findex.php%3F%2Fcollaborations%2F as the iframe src.

Any URL you Tweet will automatically be wrapped by t.co, so don’t worry about shortening it beforehand.


#5

awesome! It works perfectly!


#6

Hi there,

I am trying to display the follow us and display number of followers… I am not too sure how to do this. This is what I have thus far:

Not sure how to do this…
Shawn


#7

We tried to implement but we cannot list the # of followers…

<iframe allowtransparency="true" frameborder="0" scrolling="no" src="https://platform.twitter.com/widgets/tweet_button.html data-show-count="true" data-preview="true" data-lang="en"data-via"shawndkennedy" data-count="vertical"
    style="width:130px; height:20px;"> </iframe>

#8

I figured it out. I added https: to //platform.twitter.com/widget.js

Follow @shawndkennedy

#9

Is there anything special about the environment you’re working on – like does it try to rewrite any of the code you copy and paste in on render? Were you using the same browser throughout, and if so, which browser?


#10

#11