Creating video object keeps returning "video failed to transcode"


#1

Hi,

After I upload a video I try to create a video object by making a POST request to accounts/:account_id/videos. A few days ago, when making this request imediately after uploading the video successfully, I was receiving the error “Media is transcoding.”, but now I am receiving the error “Media failed to transcode.” which means that the transcoding process ended and it failed, and I don’t know why.

The videos with which I tried can be downloaded from here. All 3 videos work with no error if uploaded from the Twitter Ads UI.

I should mention that I am using the ‘media_category’ with the value ‘amplify_video’ in the INIT phase when uploading. A few days ago, when I wasn’t using this parameter, the video would successfully upload and then I was able to create the video object immediately without any errors, so all 3 videos are ok, i.e. they meet all the requirements.

Some video media ids that gave an error are

  • 651379179359875076
  • 651355187144101888
  • 651359803818676224
  • 651361400120434688
  • 651363630936539136
  • 651365135806664705
  • 651379179359875076

Thank you.


#2

What portion of our docs are you making use of for creating videos? While we are on the subject, have you seen our Changes to Media Upload APIs for Video announcement?


#3

@majoritasdev the UI uses an older processing pipeline. It’s not quite the same upload and pre-processing system.

Tell us some more about the video you’re uploading. Does it meet all the video format requirements found in video.twitter.com/faq?


#4

@andrs I upload videos as stated in the guide at https://dev.twitter.com/rest/reference/post/media/upload-chunked, and using the parameter media_category with a value of amplify_video, and then I try to create a video object by making a POST request to accounts/:account_id/videos (https://dev.twitter.com/ads/reference/post/accounts/%3Aaccount_id/videos).
Yes, I’ve seen that announcement. That was actually the news that made me make this change now.

@brandonmblack I see. About the videos, I posted a link in my original post, from where you can download the 3 videos I tried this with. Please know that the upload with all these 3 videos worked when I tried it without the parameter media_category (so I gather they certainly meet the necessary requirements), but since I’m using this parameter, when I try to create the video object (before the video is done processing) the response is “video failed to transcode” in the last days, and before, the response was “video is transcoding” which is the response I am expecting.

The videos meet all the requirements stated at https://dev.twitter.com/rest/public/uploading-media#videorecs, but I see there are diferences between these requirements and the ones at https://video.twitter.com/faq - which ones should I follow? For example, at the latter link the maximum video length mentioned is 10 minutes, but at the former link this is between 0.5s and 30s.

I posted below screenshots with all the settings for each video:

SampleVideo_1mb.mp4

SampleVideo_1080x720_5mb.mp4

SampleVideo_1080x720_12mb.mp4


#5

Anybody?..

We cannot create video ads with the new parameter media_category=amplify_video and this will be required after October, 22nd, so it should be fixed by then.
I tried with different videos and none of them worked.

Thank you.


#6

It seems this error doesn’t prevent the ad creation anymore. I hope this was a temporar issue, and that it won’t happen again.

Thank you.


#7

@majoritasdev to confirm, you’re now seeing these video’s transcode correctly? The video bitrate you’re using is lower than recommended (4000kbps vs 5000 kbps recommend), but I’m not certain that would prevent successful transcoding.

What video formats are supported?
For video upload, we currently support “mp4” and “mov”. Videos should have an aspect ratio of 16:9 and should be encoded using the “High Profile” h.264 video codec and the AAC (Low Complexity) audio codec.

The source video bitrate should be as high as possible. We recommend a video bit rate of at least 5000k bits, and the audio bitrate should be 128k.

Frames per second should be preserved as per the original source material.

Source: https://video.twitter.com/faq

One thing that could have been the issue… previously, we supported only 15MB and up to 30 seconds of video. Your video is 11.9MB and in some cases we’ve seen that was close enough to the 15MB limit that processing the video would fail. However, on 10/22 with the introduction of the media_category param we are now processing everything asynchronously and we’ve not seen that issue return.


#8

Thank you, @brandonmblack, for clarifying. I confirm that now the videos are transcoding correctly (I tried with the last one, of 12.3 MB).

Please note that the link https://video.twitter.com/faq is no longer available, it redirects to https://video.twitter.com/about now.


#9

@majoritasdev fantastic. Sorry you ran into this trouble, but glad to hear it’s resolved. Thanks for marking the solution.


#10

I think in order to access that page you have to be logged into an account with video access in ads.twitter.com. We’ll work to get that content in dev.twitter.com later today.


#11

@brandonmblack Thank you. Indeed, I logged into Twitter and the content is available.