Create new widget



I’m trying to create a twitter widget ID. I go to “settings”, click on “widgets”, click on the button “Create new” and all I get is a drop down. From what I’ve seen on tutorials once I click that button I should then see an auto-generated twitter widget ID. If I’m doing something wrong please let me know.


If you would like to embed an embedded search timeline then will help you generate a new widget ID for the saved search query.

If you would like to embed a Twitter profile, list, collection, or likes then will generate HTML for use on your site. No widget ID needs to be generated for these data sources.


Is there absolutely no way to get a widget ID for a profile any more? It seems that lots of people are not in a position to use the new format that you mention. In my case I am tied to an old, widget-ID-demanding version of Jetpack Twitter Timeline because the institution I work for has not updated the plugin, which is out of my control.

Could you not have the numeric version of Twitter usernames – which users can check with converters online – function as widget IDs in such cases (by burying that number in a specific, available range of the longer widget-ID format, say)?


If you are using a version of Jetpack before 4.1, Jetpack 4.1 release blog post, you should update to take advantage of new Twitter features and Jetpack features in general.

Many WordPress authors are able to place the HTML content generated by into a text / HTML widget area.


Thanks for the quick reply.

Yes, we’re on 4.0.4. I’ve just emailed the tech overlords who control our lives to ask about an update.

I’ve also tried your HTML widget solution, and it kind of works, but it’s extending the HTML widget way beyond the content of the page (even when I specify a height in Is there parameter to limit the number of tweets shown or some such?

An imperfect solution I’ve found is placing the Twitter HTML in a constrained area, but let me know if there’s a better way (removed opening of div tags so that this would show):

div style=“height:400px;overflow:auto;padding:8px”>


I’m afraid this solution has now broken down, as Wordpress is stripping out the “script” tags in the code generated at

I’m not sure how it was working in the first place, because it seems to be doing this as soon as I save the HTML widget contents now.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.