Could not connect to Twitter. Refresh the page or try again later


#1

I created a Facebook Aplication on Facebook/developer, and that works fine on my website. I created a Twitter Application on Twitter/developer, website and the only thing works is ,“Live Search”. The,“Twitter Connect” button will not connect. A white page appears with the words,“Could not connect to Twitter. Refresh the page or try again later.” I have had two Technicians install my website’s Twitter integration module and both times the same error shows up. I have tried: Clearing cacha, Firewall problems, deleting temp internet files, re-installing the module and reinstalling my website. Nothing seems to work. I will preciate any suggesting. I am in the process of searching for a new module.


#2

Hi,
Im using the Abraham Williams OAuth library to integrate with Twitter API. It seems that this is an error generated from the library, not from Twitter.

From redirect.php file,

/* Build TwitterOAuth object with client credentials. */
$connection = new TwitterOAuth(CONSUMER_KEY, CONSUMER_SECRET);

/* Get temporary credentials. */
$request_token = $connection->getRequestToken(OAUTH_CALLBACK);

/* Save temporary credentials to session. */
$_SESSION['oauth_token'] = $token = $request_token['oauth_token'];
$_SESSION['oauth_token_secret'] = $request_token['oauth_token_secret'];

/* If last connection failed don't display authorization link. */
switch ($connection->http_code) {
    case 200:
        /* Build authorize URL and redirect user to Twitter. */
        $url = $connection->getAuthorizeURL($token);
        header('Location: ' . $url);
        break;
    default:
        /* Show notification if something went wrong. */
        echo 'Could not connect to Twitter. Refresh the page or try again later.';
}

we can see that $connection->http_code fails to the case 200.

Im trying to find where is the error. As the library was not updated, something with our app, server or code is wrong.


#3

Well, I was looking for my profile page at Twitter Dev, and suprise! My App isnt registered. So, I believe that I dont have any consumer key/secret working. Bang!
I tried to register the same site again, but Twitter said that it cant be registered. There is an app with the same link registered by “Name” user. It doesnt say that the app was registered by me before.
So, I believe that there is something wrong with Twitter… Was I banned? I didnt find any email or message.


#4

My Twitter Integration App is working now. The problem was my CallBack URL. The moment I correct it. My website Twitter Module started working with no issues.


#5

Hi! How did yout corrected your callback.php?
My others sites with the same module were not deleted from Twitter and still have the same issue… so I believe now that the problem is my code.


#6

My d2twitter module home page : http://www.myellowbus.com/m/d2twitter/home/

My d2twitter application callback URL:http://www.myellowbus.com/m/d2twitter/callback

My itwitter website home page:http://www.myellowbus.com/m/itweet/home/
My itwitter application callback URL:http://www.myellowbus.com/m/itweet/

Both Modules are working great now! I hope this helps.


#7

You need to set the callback url on dev.twitter.com AND on config.php to make it work!


#8

Thanks for the tip…I set my callback and now it works fine.


#9

Suddenly l cannot get Firefox to open Twitter login page and l get invalid characters on https://www.twitter.com. l recently installed Javascript on my desktop and l don’t know if this has anything to do with this problem.Can anyone help?
Thanks


#10

what’s the solution ?


#11

YES! That was the problem. Need to set callback URL in config.php AND twitter APP settings. Thanks!


#12

I have the same problem …


#13

The certificate that Chrome received during this connection attempt is not formatted correctly, so Chrome cannot use it to protect your information.
Error type: Malformed certificate
Subject: twitter.com
Issuer: VeriSign Class 3 Extended Validation SSL CA
Public key hashes: sha1/FXnwvO30nbpcJgjDK6bH+rGSqEo= sha256/qaKZwjzvNNGAc/ryUbwfqL2oArYbz4OPU22TnZ8MxNc= sha1/rkrX+bOA4RKTMrtS3loJDFIbM9A= sha256/OTV6OSADZrQuFMItaBc+5XvItK1Ljeify/yvIthNjvM= sha1/sYEIGhmkwJQf+uiVKMEkyZs0rMc= sha256/JbQbUG5JMJUoI6brnx0x3vZF6jilxsapbXGVfjhN8Fg=


#14

pls reply asap


#15

i got same problem, using chrome based Comodo dragon web browser.

can access twitter with firefox, but cant with chrome based browsers.

checked already internetz for any solution, but so far didnt yet found any…


#16

What is the reason?


#17

Why is it i cannot access??!?!? wth is this?!


#18

thank you


#19

I cannot connect to my twitter from my system through chrome browser. it is showing as
Cannot connect to the real twitter.com

Something is currently interfering with your secure connection to twitter.com.

Try to reload this page in a few minutes or after switching to a new network. If you have recently connected to a new Wi-Fi network, finish logging in before reloading.

please help me out.

If you were to visit twitter.com right now, you might share private information with an attacker. To protect your privacy, Chrome will not load the page until it can establish a secure connection to the real twitter.com.


#20

hi guys! I’m getting your ideas right. but I’m still outputting “Could not connect to Twitter. Refresh the page or try again later.” also I’m using Abrahams’ API…

my site here is :http://**/newf/twitter/
my call back url is : http://
/newf/twitter/callback.php

Any idea where would be my mistake here?