Could not authenticate you (tried multiple apps, accounts and wrappers)


#1

Hi, as per the title I’ve tried to post a tweet via single-user API and statuses/update through multiple means, I have regenerated the tokens for both App and the Access tokens. I’ve tried another account I had (made a new app etc etc) I tried both the ricardoper and j7mbo PHP implementations.

I’m keeping ti simple, only posting the word “test”. All return 32: Could not authenticate you.

The API status says it’s working… I don’t know what else to try. My app ID is 13674627, I’ve triple checked the token values. I even tried GET instead of POST. The URL is https. I’ve checked all the other forum posts and stackoverflow articles about it.

The Test OAuth button 404s (apparently discontinued but not removed)

Please… help!

UPDATE: I don’t know why the other wrappers were failing but using the ricardoper one gives “could not authenticate” response when the status value is not set correctly (I’d accidentally used 'array(status,'value)' instead of array('status'=>'value')

Left my folly here in case it helps other people