Constantly Failed to proxy image


#1

Hello,

I am trying to validate najture.com and I keep getting ‘Failed to proxy image’ and once in a full moon ‘unknown image aspects’.

This also goes for any sub page I try to validate.

The meta tags for a main page:

Header on response when getting the image:

Cache-Control:max-age=3600, public
Connection:Keep-Alive
Content-Length:4338
Content-Type:image/jpeg
Date:Sat, 14 Dec 2013 19:26:55 GMT
Expires:Sat, 14 Dec 2013 20:26:55 GMT
Keep-Alive:timeout=5, max=98
Last-Modified:Fri, 06 Dec 2013 16:24:26 GMT
Pragma:cache
Server:Apache

A sub page http://najture.com/image/9H9gO7Q6To :

Response headers for the image:

Cache-Control:max-age=3600, public
Connection:Keep-Alive
Content-Length:58139
Content-Type:image/jpeg
Date:Sat, 14 Dec 2013 19:24:33 GMT
Expires:Sat, 14 Dec 2013 20:24:33 GMT
Keep-Alive:timeout=5, max=99
Last-Modified:Sat, 14 Dec 2013 15:38:47 GMT
Pragma:cache
Server:Apache

Robots.txt :

User-agent: *
Disallow:

I am out of idea’s why the proxy fails to fetch the image while I see in the server logs it actually fetches it about times.

Any help would be appreciated.


#2

Are there any requirements on the HTTP headers of the images being served?


#3

Please check your robots.txt. Here’s what we see:

Image URL http://najture.com/i/s/9H9gO7Q6To.jpg
Robots URL http://najture.com/robots.txt

User-agent: *
Disallow:


#4

I’m confused. I am seeing exactly the same? I allow everything with the robots.txt?


#5

It looks like you disallow everything, so we can’t crawl your images.


#6

User-agent: *
Allow: /

Same result. And :

User-agent: *
Disallow:

Should also allow everything


#7

Twitter Cards stopped working for http://staggerd.com a few weeks ago. Not sure why as Twitterbot is allowed to crawl. ^NE


#8

Could you please remove the Twitterbot “Disallow” directive entirely from your robots.txt file and see if that works? The Twitter Cards validator is currently timing out when I try to validate your domain name. Thanks! https://dev.twitter.com/docs/cards/validation/validator


#9

@romainhuet

Thank you for responding! I actually found your advice in another post. :slight_smile:

I changed our site’s robots.txt yesterday and flushed it from MaxCDN so it reflected the changes right away. I’ve been checking to see if that changes our situation but I am still getting the “Internal Error. Try again later” and the “exceeded 15.seconds to pink-floyd while wait” error messages.

As previously mentioned, Twitter Cards were previously displaying but they suddenly stopped showing a few weeks ago. Not sure what caused this. Any more tips? Thanks! ^NE


#10

Are you using MediaTemple? I know they were blocking our crawlers at one point, but that shouldn’t be the case anymore.


#11

@rchoi

As a matter of fact, I am! We moved to (mt) a few weeks ago (https://twitter.com/StaggerdGroup/status/376942976867385345) and after that the cards haven’t been displaying.


#12

Got in touch with @mediatemple. This is what they had to say:

Thank you for your inquiry to (mt) Media Temple.

"Because Twitter Cards are not (mt) Media Temple software, we cannot offer direct support. For more information regarding what is and is not supported by (mt) Media Temple, please refer to the following (mt) site:

Statement of Support

That being said, we are not aware of any issues with Twitter Cards being blocked by (mt) Media Temple’s servers. If you can obtain the IP address(es) that are accessing (mt) Media Temple from Twitter Cards from their support team and provide them to us, we can check our firewall to see if anything is being blocked.

If you have questions about the information within this support request or any of your (mt) Media Temple services, please feel free to contact us at any time."

Any thoughts?


#13

I’m having a similar problem - except I just got approved. The post is missing the image however.

	<meta name="twitter:card" content="summary_large_image">
	<meta name="twitter:url" content="http://www.ilostabet.org/">
	<meta name="twitter:image:src" content="http://www.ilostabet.org/img/twitter-thumb.jpg">
	<meta name="twitter:image:width" content="480">
	<meta name="twitter:image:height" content="480">
	<meta property="og:site_name" content="I LOST A BET.org">
	<meta property="og:type" content="website">
	<meta property="og:url" content="http://www.ilostabet.org">
	<meta property="og:title" content="When you lose a bet, you gotta pay the piper.">
	<meta property="og:image" content="http://www.ilostabet.org/img/share-thumb.jpg">
	<meta property="og:description" content="No pain, no shame. This guy had to shave half of his head, and he got off easy. If you've ever made a bet, check out ilostabet.org.">

#14

Thought I’d add, I did notice the validator displays the facebook og tags with meta name instead of meta property - which facebook then says is invalid og code.


#15

You can reply with our IP address and ASNUM, as defined here:

https://dev.twitter.com/docs/cards/troubleshooting#When_I_validate_I_get_the_message_exceeded_15.seconds_to_pink-floyd_while_waiting_for_a_response_for_the_request_including_retries_if_applicable


#16

Your robots.txt disallows images.

http://www.ilostabet.org/robots.txt


#17

Ryan, I received another message from them. It reads as follows:

"Thank you for your response.

I can confirm that we are not blocking any IP’s in the range of

199.59.149.0/26
199.59.149.128/26"

Any idea what else could be causing our issue? Thanks! ^NE


#18

Update:
One of my URLs just validated. When I tried doing a different one it failed. Here is a screenshot:

http://geekga.sm/img/temp/twitter-cards-validator.png

Also, the URL that validated works as shown at https://twitter.com/raccooncitynews/status/421887835772170240. All other URLs fromt he same domain do not. Weird.


#19

Update: Not sure why it was or what it is but Twitter Cards work now.

Question: I changed the card type to Summary with Large Images. How long until it gets approved? The URL that was validated for submission was http://staggerd.com/10976/stylo-alex-metric-remix and the contact username is @geekgasm.

Thanks, everyone! :slight_smile: