Connection refused when fetching a summary card


#24

I have passed this issue along to the Cards engineering team and will respond here with updates. This is being tracked internally as PREL-12939.


#25

Thanks @jbulava. I’ve tested today with this link: https://www.talenteca.com/empleo/mexico/cuautitlan-izcalli-edo-de-mex-/auxiliar-de-almacen/5522c5305801005601543fcd and the large-summary-card is not being showed.


#26

As engineering continues to investigate on our side, I’ve been asked to inquire about the hosting service providers used by those affected. Could you please respond here with that information?


#27

jbulava,

I am using certifiedhosting.com for my server hosting.

Greg


#28

it’s been officially over a month since my player cards stopped working…


#29

@jbulava our site is hosted in AWS-EC2


#30

We are using Vidahost Cloud and have sitewide SSL enabled. We have a couple of sites on it using cards, both configured identically. bathmums.co.uk continues to work fine, espanabreaks.com cards worked initially then broke. The latter has a fairly new certificate (<2 months old), the former was first issued in 2013 and renewed about 6 months ago.


#31

I’m facing the same issue — my cards (e.g. http://overca.st/CdT4UF_0) stopped working at the same time and produce the “connection refused” error as well. Nothing changed on my end that would break this, as far as I know. The SSL certificate has remained constant.

I’m hosted at Linode, but I bet that’s not the issue. My SSL certificate is still signed with a SHA-1 signature, if that helps — ultra-strict implementations are beginning to show warnings about those. (I can’t upgrade without breaking some old SSL-pinned clients, so I’m waiting as long as I can.)


#32

We encounter the same ssl issue. We bypass the issue by redirecting the twitter user agent to the http site and all other requests to https.

Now we can use the validator with the http url, twitter can fetch the card metadata, and all regular users are redirected to https.

This is only a temporary fix but it’s working for now.

Here some configuration example for Apache :

RewriteEngine On
RewriteCond %{HTTPS} =on
RewriteCond %{HTTP_USER_AGENT} ^Twitterbot/(.)$
RewriteRule ^/?(.
)$ http://%{HTTP_HOST}/$1 [R=301,L]


#33

I’ve upgraded my certificate to SHA-256 and removed an HTTP-to-HTTPS short-domain-to-long-domain redirect. The SSL implementation gets an “A” from the Qualys SSL test (although it did before, too). New link example: https://overcast.fm/+DCGWw7c

The problem persists.


#34

Upgrading OpenSSL fixed this for us.


#35

This has been fixed for my site sometime in the last 48 hours or so. Fixed for everyone, or just me?


#36

It seems to be fixed for our site, too!

:smile:


#37

Connection isn’t refused anymore, but the Player Card preview is not a preview of my card, it’s some Twitter Error image:

Using https://omgtap.co/userfiles/10000/10001/blogs/1425895180_I_Have_Evolved/ as the link being fetched…

Image being displayed instead of my Card Preview is:

Greg


Error on card preview: Fetching the page failed because connection is refused
Unable to render Card preview and No Log
#38

As some of you have noticed, there was a fixed pushed to production last week to address this issue. Apologies for the long turnaround time.

@OMGUrOnline, I’m looking into your URL now to help debug the issue.


#39

I’m seeing intermittent errors when submitting your URL or even testing your tags and image on my own domain. Some times the card previewer succeeds while other times I get the robot or “unable to render.” Engineering has acknowledged my internal ticket (PREL-13364) and is investigating.


#40

Thanks Jon!

My cards stopped working on March 6th (last good one posted on March 5th). It was a couple weeks before I saw any other postings concerning this issue. From that point on, the validator refused the connection. The other day when the fix was pushed is when the validator started reproducing erratic results (not reading, reading but not rendering, etc…)

I have contacted my server company and they changed the following in my ssl.conf:

ServerName omgtap.co
ServerAlias www.omgtap.co

All http://www.omgtap.co requests are redirected via my .htaccess to https://omgtap.co with the following:

RewriteEngine on 
RewriteBase /
RewriteCond %{HTTP_HOST} ^www.omgtap.co [NC]
RewriteRule ^(.*)$ https://omgtap.co/$1 [L,R=301]

All non-https requests WERE being redirected to https with:

#RewriteCond %{HTTPS} off
#RewriteCond %{HTTP_HOST} ^omgtap\.co$ [NC]  
#RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301] 

but I disabled that so that the Player Cards would work by posting them with non-ssl links (which they worked that way - but I haven’t checked them in a while).

I know you probably have this info in previous posts, but i’m including it in case it might help.

Thanks,
Greg


#41

Thanks @jbulava, working fine now the summary card on the timeline feed.
But having the same issue with the card previewer, (the thing about the robot or the “unable to render”)


#42

Thanks God all my cards are working perfectly. Good Luck 4 u.
http://www.tekmx1.com/


closed #43