Coldfusion call to get user timelines stopped working


#1

My code worked fine up until 2013-12-10 18:26:00 (roughly). But I can’t get it to work since. I have created a new app and used the key’s provided but still no luck. I keep getting timed out.

Can you see a problem with my code.

 <cfset consumerKey = "NM**********************a5w">
	<cfset consumerSecret = "shQMl************************************************H4F0">
	<cfset bearerToken = ToBase64(consumerKey & ":" & consumerSecret)>
	<cfset authorization = "Basic " & bearerToken>

	<cfhttp url="https://api.twitter.com/oauth2/token" method="post" charset="utf-8">
		<cfhttpparam type="header" name="Authorization" value="#authorization#">
		<cfhttpparam type="header" name="Content-Type" value="application/x-www-form-urlencoded;charset=UTF-8">
		<cfhttpparam type="body" value="grant_type=client_credentials">           
	</cfhttp>
	
	<cfset bearerTokenResponse = DeserializeJSON(cfhttp.fileContent)>
	<cfset authorization2 = "Bearer " & bearerTokenResponse.access_token>
	
	<cfhttp url="https://api.twitter.com/1.1/statuses/user_timeline.json" method="get" charset="utf-8">
		<cfhttpparam type="header" name="Authorization" value="#authorization2#">
		<cfhttpparam type="url" name="screen_name" value="fifecouncil">
		<cfhttpparam type="url" name="count" value="3">
	</cfhttp>
	
	<cfdump var="#cfhttp.FileContent#">