CDN server preventing images on twittercard


#1

On MaxCDN I have HTTP Referrer Whitelist set for my domains to prevent hotlinking. However doing this prevents twitter or other sites picking up images from my CDN.

I’ve tried adding *.twitter.com & other variations to my referrer whitelist however that doesn’t help.

Should I completely disable referrer whitelisting on my cdn or am i simply adding the wrong domain to my whitelist?


#2

I am having the same issue, cards work fine on the test server but the live server (also MaxCDN) does not show the cards. Any advice would be gratefully received/


#3

I would consider these techniques to allow access based on User Agent, if it helps?

https://dev.twitter.com/docs/cards/troubleshooting#robots


#4

Thanks for your response @rchoi, it was simple in the end I just didn’t know where to edit the robots.txt file.

@wengerball. Remove your whitelist settings, this will just cause 403’s when twitter tries to read image. Go to your pull zone and manage. There is an SEO tab where you can turn robots.txt on and enter custom values. Just enter these and all should be working again.

User-agent: Twitterbot
Disallow:


#5

@petermeech,

Thanks for updating us. It’s a little tricky, and glad you got it working!

(Also really happy you’re sharing back to others; super helpful.)

Let us know how we can be of use moving forward!