Cards not Working for me


#1

I’ve done the validation and it says I’m whitelisted. Does that mean it should be working?
When I tweet, I don’t see the card even in details view. Here is an example url:

Any suggestions?
Thanks,
Sam


#2

Hi Sam, your summary Card seems to work for me (see below screenshot)! You may want to consider adding an image though using the twitter:image or og:image meta tag. For more information on all Summary Card meta tags, go here.


#3

I think I don’t know how to use twitter cards. If I have a link to a page on my site in a tweet, shouldn’t the summary card come up? It doesn’t seem to for me… What am I missing?

Thanks,
Sam


#4

Hi,

I noticed the card works when my jetpack automatically sends out tweets when I publish. But when I manually copy a url from my site into a tweet, no card comes up. What am I missing?

Thanks,
Sam


#5

I have same problem. *.ticket.st is whitelisted for summary card, but no card comes up.
Need another step ?

https://twitter.com/kanjani8_ts


#6

There’s no Cards markup on that page (just checked in the validator).


#7

hi i have same problem if check with validator working, but if i test for twitt not show twiiter card.

test this my page http://estandstore.com/bigmo-sleeve-for-macbook-air-11.html


#8

Product cards are deprecated and will cease to work in the next few weeks. You might want to try changing to a summary card.


#9

Hi Andy,

I’m started this thread but still haven’t been able to find an answer. I’m using jetpack to send out tweets automatically when I post, and cards work just find for this. But when I tweet manually with a link to my page, the cards don’t show up. Is there some special way to get cards to work that I am not aware of?

Thanks,
Sam


#10

I’m still hoping someone can help me here. My twitter cards don’t display when I put a url to a post in a tweet. Any thoughts anyone?

Thanks,
Sam


#11

I’m unclear what is happening here. The link you started the thread with does appear to have the right tags. However, it is one of the “attachment” pages on your Wordpress site, and has a strange URL as a result.

I just tried another one of your posts http://tall.life/an-old-house-for-tall-people/ and posted the link directly into a Tweet - a card appears to show fine.

So my suspicion here is that this is to do with attachments/standalone images, vs full posts.


#12

You are right, it works for posts but not attachment pages. The attachment page url I gave is strange because I’m storing some strings in it to point to the next or previous image in a media category. But I tried it with the basic attachment page url and that didn’t work either. I wonder if anyone else has wanted to do this, use twitter cards with an attachment page, can you think of anyway to make it work?

Thanks,
Sam


#13

Yeah, this is weird. Actually I think I noticed that you don’t have an image specified for the card in the attachment link? That’s the only potential discrepancy. Otherwise it could be the URL format which we’re not handling correctly in the Cards renderer.


#14

Here is an image attachment page url where a feature image has been specified, still doesn’t work with this one:

it isn’t a big deal, but perhaps other people might have this issue too.

Thanks for you help,
Sam