Cards not showing with 301 Redirect


#1

Hi there!

We’re trying to show summary_image_large cards with a custom shortener that basically just 301 Redirects, for example from http://saveli.st/VyuCY9Wc ==> https://savelist.co/product/mario-maker-artbook-figura-amiibo-mario-30-aniversario/55aeba15880c188d8662c6ce

The Card Validator correctly renders the card and we made sure we aren’t having any robots.txt/caching issue, but we still don’t know why the cards are not showing. We are getting this warning:

INFO:  Page fetched successfully
INFO:  31 metatags were found
INFO:  twitter:card = summary_large_image tag found
INFO:  Card loaded successfully
WARN:  this card is redirected to https://savelist.co/product/mario-maker-artbook-figura-amiibo-mario-30-aniversario/55aeba15880c188d8662c6ce

Any help from the Twitter Cards team will be greatly appreciated.

Thanks!


#2

@SavelistCo, when I Tweet http://saveli.st/VyuCY9Wc, a card renders just fine in the card details permalink view.

Cards currently do not render in the timeline of desktop twitter.com. Maybe that’s the issue you are seeing.


#3

Thanks for the reply @joncipriano. I just posted this tweet with my personal account from the official Android client, and I can’t see the card in the detail view in Android: https://twitter.com/FdezRomero/status/628294586813820929?s=09

Are we doing something wrong? I also checked from iOS and I can’t see the card.

Thanks!


#4

I don’t see the Card either. However, when I Tweeted the same URL from a test account the Card showed up fine. Do you happen to have any other Tweets with non-working Card URLs? Since we have Mario and Zelda already, perhaps another Nintendo themed product? :smiley: Your redirect shouldn’t affect it. We use short URLs all the time.


#5

Hi @joncipriano, I tweeted a link to a Yoshi amiibo from the web (to continue the Nintendo theme) and this it worked, I can see the card in both the web and Android :smiley: https://twitter.com/SavelistCo/status/628487157490012160

However, I tweeted another link from Android (a Kirby tshirt :wink:) and the card is not showing neither in the app nor the web (like in my first post): https://twitter.com/FdezRomero/status/628489325127335936

Is there any difference on how the tweets (or metadata) are sent depending on the platform?


#6

@SavelistCo, looks like we have a legit issue. I was able to replicate with another Summary Card, so it’s not your implementation. I’ve logged the issue internally and will post back here when I have an update from the team. Thanks for reporting and helping debug!

Tracked internally as CK-1488


#7

Hi @joncipriano, any news about issue CK-1488? Was it finally fixed?

Thanks.


#8

We believe it was fixed, but forgot to update this thread. Are you still seeing an issue here?


#9

@andypiper It’s working for me, but I didn’t know if it was totally or partly fixed. Thanks!


#10