Cards not rendering, validator says no metatags found. They're there


#1

Pretty regularly, cards for new posts from our site will not render. When we check the URLs in the validator, we get the following messages after a few seconds:

Unable to render Card preview
INFO: Page fetched successfully
WARN: No metatags found

Other posts do tend to render properly and validate properly—including posts that didn’t when they were first published.

Here’s the URL that’s causing us problems today:

Here’s one that didn’t validate initially but then worked later (and works now):

Troubleshooting steps attempted [note that we will not prioritise posts unless there is evidence of following the troubleshooting guides]:

I’ve gone through each of the recommended steps in the link above. I’ve checked the card type (summary); I’ve verified that the content and images can be reached; I verified that we’re not blocking Twitter’s bot; I verified it’s the right URL; I inspected the source HTML and manually checked that the tags are there; I switched from using Yoast’s WordPress plugin to generate the tags to using your own. I went through your whole list. None of these things seem to be the problem. And the fact that previous posts experienced the same problem but then worked later is even more strange. I even tried clearing our cache when this was happening in the past, and that didn’t seem to make any difference either (besides, I’m seeing that the tags are rendering in the code).

Any advice or assistance would be greatly appreciated.


#2

Update: As I anticipated, the card for the Ring post that I listed above is now rendering properly, but they aren’t for newer posts. Newer posts show the same error in the validator. Is there anything that might be getting cached in how you’re reading WordPress site content and tags? Thanks again for any assistance you can provide.


closed #3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.