Card Validator - Unable to Render Card Preview


#1

Hi - using the card validator, however when I type in my website (zipwines.com), I keep getting “Unable to Render Card Preview”. The log seems to show the card is validated, but the card itself is not rendered.

See this screenshot: http://imgur.com/Kxey7JV

Also when I hit the validate button again, sometimes I just get “Unable to Render Card Preview” without any info in the log.

See this screenshot: http://imgur.com/crsA70m

I believe I have my meta tags set up correctly, and in fact at one point the card validator lit up green, but then I haven’t been able to get it to do it again.

The website I’m trying to render is http://zipwines.com.

Can you please assist?


#2

@zipwines, I believe we had a high level of traffic to the validator at that time. Your Card displays for me in the validator as expected; can you confirm that you see the same now?


#3

Same problem for me , when i do the following
curl -A Twitterbot http://app.courtingthelaw.com/selected_question/here-1
Result is following

    <html>
    <head>
    <meta name="twitter:card" content="summary" />
    <meta name="twitter:site" content="flickr" />
    <meta name="twitter:title" content="Small Island Developing States Photo Submission" />
     <meta name="twitter:description" content="View the album on Flickr." />
     <meta name="twitter:image" content="https://farm6.staticflickr.com/5510/14338202952_93595258ff_z.jpg" />

    </head>
      <body>

      </body>
    </html>

But card validator says that no unable to render card preview


#4

I’ve just tried this in the validator and it seems to work fine for me.


#5

try this curl -A Twitterbot http://app.courtingthelaw.com/selected_question/here-1 , because here was previously cached


#6

I also changed content inside the meta tags with the actual content


#7

This worked 25 minutes ago but now the validator says no meta tags are returned by your page. I’m afraid I don’t know what changed or what you’re trying to achieve here. You shouldn’t keep trying to validate the same page / URL over and over with the same content, because the Cards crawler will cache your tags and content for up to 7 days.


#8

did you tried the curl ?


#9

I actually want a small preview when sharing url of my web . I think There are some extra meta tags also except the twitter owns , like http-equil


#10

Yes, I just tried the curl, and you’ve changed the content again, and as I mentioned this is not helpful to keep trying to validate due to the caching. The validator now returns “no metadata found” so I don’t know what you are doing with your site or why this is broken.


#11

Hi. When i try to validate my link ( http://share.glide.me/sarah/1nszuna3 ) I get it validated but i see the video too small with a black frame around it. And when i check it in the twitter site https://twitter.com/search?f=tweets&vertical=default&q=share.glide.me&src=typd i get only voice without any picture.

Any idea?!


#12

weird… the specific video that i wrote here is working now but all the others on share.glide.me aren’t and also the video that is showing is still too small…


#13

can you help me how to take permissions from twitter to tweet images


#14

Do you want to Tweet an image from an app, or do you want to share an image with a Tweet when a user adds a link to your URL? These are two different things. I would recommend opening a new topic in the appropriate category rather than responding on this thread about Card validation.


#15

Got the same error.

It works for already whitelisted domains:
https://raw.githubusercontent.com/nanvel/twitter-card/master/index.hml

The same page doesn’t work from s3-us-west-2.amazonaws.com (not whitelisted):
https://s3-us-west-2.amazonaws.com/bkstg-persistent/twitter-cards/page.html

As well as for
https://s-bkstg-api-dev.aws.bkstg.com/jRJHpgN

Validator error is:
Unable to render Card preview

Review response:
The URL you provided for bkstg to use the player card is inaccessible.


#16

Hi,

I have the same problem. My URL is

https://ec2-54-164-104-199.compute-1.amazonaws.com/player/page.html

It says “11 metatags were found” but “Unable to render card preview” with a warning that the domain is not whitelisted.

I can see your crawler getting the preview image in my logs… I don’t quite understand what I’m doing wrong.

Appreciate any help!


#17

It doesn’t look like you’re specifying an actual media file or stream with a fully-qualified path to be presented in the player.


#18

Hi Andy, Thanks for the fast reply! I think I’m missing something. The documentation allows for having a player without a player:stream, saying " if you only supply a twitter:player with no twitter:player:stream, you’ll get a static, non-playable image." but I’m not seeing that. Nevertheless I put in a player:stream etc. and I still have the same issue, unable to preview. I’ve also made the url in container.html absolute. For the time being I’ve made everything use your example.png and example.mp4 as well, but I still have the same issue.


#19

Hmm. I don’t have time to validate this locally at the moment, I’d have to find time to have a go at this myself to debug further. Puzzling.


#20

OK Thank you for your help and please keep me posted!