Card validator 'Unable to render card preview'


#1

Hello, I’m trying to validate the URL https://www.citasmandela.com/ but always get the message: ‘Fetching the page failed because the fetcher cannot resolve the address.’ This website was already approved for photo cards but we had to change the domain name. Nothing else changed.

Do you have any idea?

Thanks!


#2

It looks like your image is not accessible:

https://www.citasmandela.com/system/images/tw/QuotesMandela_Thumbnails_1.jpg.jpg


"Unable to render Card preview"... with an empty log!
#3

Thanks for your answer but this was a recently added error when trying to change the image to check the validator.

The image URL is fixed again and still ‘the fetcher cannot resolve the address’…


#4

Still the fetcher cannot resolve the URL, is this a bug? Could anybody, please, say anything?

Thanks.


#5

Turn it to http instead of https and run through the validator again.

Thanks!


#6

Thanks a lot for your answer. It worked and I was able to submit for approval.


#7

That solution didn’t work for me. I’ve tested on both HTTP and HTTPS.
Still getting: Fetching the page failed because the fetcher cannot resolve the address.

I can browse and curl the url without any issues.

Any advice would be appreciated.


#8

Could you provide the URL you’re trying to validate?


#9

Hello I’m facing same issue, I feel the link has some problem, any inputs on the following link?
http://snap.karmasnap.com:8080/KarmaSnapServer/test.html


#10

i think your tag is wrong…
< meta … >

use following tag:

< meta … / >

WARNING: Dont forget to close tag />


#11

Hi @JJayyu, I cannot get to the page and receive a 404. Should it still exist?


#12

thanks for the reply @efriandika,

I have made the changes, still having the same problem.
had you faced the same issue?


#13

Hi @jbulava sorry, we had some changes made, please check its accessible now.


#14

Hi all I am having the same problem We’ve never setup twitter cards for this site but am getting the “unable to render” message anyideas? This is the url I am using (I’ve tried others) http://torquedata.com.au/4-tips-capturing-maintaining-right-data/


#16

Hi @Torquer, your card renders for me in the validator. I think the only issue you might have is with the twitter:domain meta tag. It is not required, but if used it needs to be a valid URL, not a title. I would remove the entire tag or change its value to http://torquedata.com.au.


#17

Hi,
I got the same issue,

INFO: Page fetched successfully
INFO: 13 metatags were found
ERROR: No card found (Card error)

My website is http://dreammy.org any solution?
Thanks


#18

I am having the same issue for http://ianbillen.com


#19

Your card looks good to me - your site is whitelisted, and a summary card is attached to links to blog posts etc. Your top-level homepage does not have a twitter:card element.


#20

I cannot see a preview of my card at http://www.wiggletot.com. I have changed the twitter card four days ago and it still shows the old card when i post something on twitter. any suggestions? My web developer says twitter sometimes takes a long time to upload pages but I don’t think it would be this many days


#21

See the Cards Troubleshooting guide section on refreshing cards. Unfortunately it can take a week or so to update things sometimes.