Card validator returns "No metatags found" but they are on the page


#1

I have all the necessary twitter tags and open graph tags on my webpage but the card validator returns:
"INFO: Page fetched successfully
WARN: No metatags found"

My webpage is http://www.condominiodeco.pt

I have no idea why this is happening. Can someone give me a clue?

Thanks in advance.


#2

I’m not clear what is going on, either - it does look like the correct tags get returned when I fetch the page as Twitterbot. Not sure what to suggest at the moment.


#3

Thanks for the quick reply.

Do you know when you can give me some info about this problem?


#4

I just tried uploading your page to a different server and it worked fine in the validator. My working assumption would be that something about the way your server is responding to the cards crawler is causing the meta tags to be stripped out. I don’t understand what that could be, since when I fetch the page using curl -A Twitterbot they show up fine.

Unfortunately a lot of folks are out on vacation at the moment so I’m not sure what more I can do to help debug this today.


#5

I’ll be on vacation as well. When I’m back in January I’ll reply to this post so we can try to find the problem.
Thanks for the support!

Happy holydays


#6

Few things to look in as well:

https://dev.twitter.com/cards/troubleshooting

For the handles, try using @CondominioDeco instead of @CondominioDeco


#7

Hello.

I came back from vacation. Do you think you can help me today?

Thanks in advance.


#8

Sorry to reply again but I’m not sure if I should create another topic or just reply to this one.

I can’t seem to find the problem, can you and your colleagues help me?

Thanks


#9

I’ll see if someone is able to look into it, but it is very strange as the exact same page works if I host it on my own server.


#10

Can it be something related to my server? The strange this is that the metatags are read by other services, like facebook and linkedin.


#11

I was having a similar issue, except I had two very similar pages where one found the metatags and one couldn’t. I looked at the differences between them and it was really only the comments. I tried removing the comments in the one page that had some in the block. That fixed the issue. It seems like a bug with the crawler. It looks like you have quite a few comments in the block, perhaps temporarily removing them is worth a shot?


#12

I have the same problem with http://wppa.opajaap.nl/my-album/?occur=1&slide&album=1&photo=1 while a development site works correctly: http://beta.opajaap.nl/?album=1e18ad62e557&slide&occur=1&photo=9c0ab8182f8b I removed the HTML comments, but that does not help. Can anybody help me?