Card validator error: ChannelClosed


#1

Hi

When attempting to validate my Twitter card I am getting the error “ERROR: Failed to fetch page due to: ChannelClosed”.

I have searched these forums and although others have had the same error returned, I’ve not been able to see a resolution.

URL: https://www.impulse-embedded.co.uk/

Yesterday I was receiving a different error which was due to security issues with my ssl. I have since rectified them (ssl rated A on ssllabs), and am now receiving the error above.

Troubleshooting step summary:

when you view the source of your page, the expected Twitter Cards meta tags are shown

Yes

NB at a minimum, your page must contain at least a twitter:card meta tag specifying a valid card type, or suitable OpenGraph fallback tags.

twitter:card etc is showing correctly

if you execute curl -v -A Twitterbot <url> at the command prompt, does your page still show the twitter:card tags in the <head> section of the page? Does your server return a 200 response code and a valid Content-Type header?

Not sure how to do this

is your page adding the tags after it is loaded, for instance using Javascript (e.g. Angular, Meteor, Google Tags Manager)? The crawler and validator cannot execute Javascript and the tags must be static.

No

is your site accessible by the Twitterbot/1.0 user-agent? Are all the files (including image files) accessible to Twitterbot? you should check http://your-site-url/robots.txt and ensure that it allows access to our crawler. If your images are on a different domain, also make sure you check the robots.txt file for that domain.

There is no block for Twitter

are you using a Wordpress (or other CMS/blogging platform) plugin? We provide our own official Wordpress plugin, but cannot easily provide support for those built by third parties . Check that the configuration includes all of the required tags. Avoid using multiple plugins at the same time, as tags will override one another.

No

are you putting the top-level site URL into the Validator, or the specific URL where your markup is present? you’ll need to make sure that you provide a link to where your Card markup is visible in the page.

I have tried it with different URLs.

are you using a supported Card type? Product, Gallery and Photo cards were deprecated in mid-2015. Is the card type spelled correctly, or is there a typo?

I am using summary_large_image

if your image is not showing, is it accessible on a URL that is not blocked by your robots.txt file? Does it conform to our size constraints? Are you using an absolute and full URL (including the http protocol piece), not a relative one?

This isn’t the issue

if you see a validator message about Fetching the page failed because other errors or similar, check your SSL configuration. The certificate and server name must match (or be aliased to match) due to Java security constraints.

I was initially receiving this error but have sorted it.

are you using a fully qualified DNS domain name? The crawler does not support dotted IP addresses as domain references, and cannot access localhost.

Yes

Any help would be massively appreciated.

EDIT: @andypiper following your comment on another post I have updated with information on my troubleshooting.

EDIT: I have done a curl request and received a response for Twitterbot:

Thanks

Ben


closed #3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.