Card error: Fetching the page failed because the request timed out


#1

Noticed over the past two days that my cards weren’t showing up so came to validator and every URL I try pulls back the “Fetching the page failed because the request timed out” error. This has been working smoothly without issue for a long time now.

Haven’t changed anything on the site, so curious as to where to start to figure out the root of this issue.

Here’s an example of a full URL that we’ve tested in the validator: http://www.insidethehall.com/2015/08/17/despite-injury-blackmon-jr-still-working-to-improve/

I can find no documentation on this specific error on the documentation page.


#3

Still seeing the same error, so I’m curious if anyone can tell me if this is an issue on Twitter or something with our site.


#4

I’m getting this same error, too. I’m trying this page as a test:

I am using WordPress as the CMS with various plugins loaded, so I created a simple test page with the same meta-tags (but loading no plugins, javascripts, images, additional header info, etc.). It’s here:

This simplified page also fails to validate with the request timed out error.

Out of curiosity, I copied the same simplified page to another host, and it does verify! It can be seen here:

So it’s not the code or meta-tags causing the issue but something associated with that one domain. Again, the domain I need validated is http://www.thelingerieaddict.com.

Could my domain be on some sort of blacklist? I’ve had the host check, but they say they aren’t blocking any IPs or bots that Twitter uses.


#5

I tried a similar test using our staging domain and the cards worked. Exact same code, but a different domain name.


#6

Very sorry for the frustrations here. We are actively investigating these multiple reports of timeouts and name resolution failures. Bear with us while we dig into this.


#7

My cards now validate. The host (Media Temple) were blocking Twitter’s IPs for some reason.


#8