Can't login from TV (webkit based browser)


#1

Ok, here is weird problem, until last Monday (30.03.2015) everything worked fine, login, tweeting, everything, but now we can’t even log into twitter from TV, login from PC work fine and we are 99,999% sure nothing is changed on our side.
So here is simplest case which not work, i load https://twitter.com in webkit based browser enter user name, pass click login and been redirected to page like if i type incorrect password, we tried 100 times with different accounts and pass but nothing helps, using same accounts on pc from same IP everything work fine.
In this scenario we get no errors, nothing, page is just reload set focus to field user name and do nothing…
Then i try to make new account from TV, but got famous: 403 Forbidden: The server understood the request, but is refusing to fulfill it.
I read all posts with this and similar errors try to apply they solutions(most of them are still unsolved) but nothing, i read api change log but nothing there, so is there anything changed on https://twitter.com page in last 7-10 days which can cause this strange behaviour, new version of jQuery or any other related library?

this me look like some incompatibility issue between webkit(538.1) and some js running on that page… anyone have idea where to look?

Edit: worse from everything is that login at https://mobile.twitter.com/ work !!


#2

I removed your Consumer key from this post as it is not a good idea to share app keys and secrets etc in public.

Which browser are you using? are you able to reproduce on any other browser or client?


#3

I read many posts with key so i post key because i get idea that is some tradition here(off course without secret key) …i will not do that in future…

Any way it is custom build browser on device, based on webkit(i post wrong version last time this is correct one 536.28), it is similar to Safari or Midori browsers…this is his agent string we send:
Mozilla/5.0 (Linux) AppleWebKit/536.28 (KHTML, like Gecko) Ekioh/2.3.4-arris-4 Safari/536.28

Strange thing is it work with mobile.twitter.com and not with twitter.com (only login part) but it worked 10 day ago on both, i read somewhere on forum that twitter did some changes on login page at 06.04.2015…so it must be related to that…

no i m not capable to reproduce this behaviour in other browsers…

PS.
we find out that our browser(from device) do not send fields computer screen width and height so if some code relay on that values it may break…

Edit:
i think problem is related to this topic Request token error but only in official Twitter iOS client's web browser window, look 4th post there…


#4

Hopefully some fixes we added yesterday should have resolved that (still verifying) - are you still having an issue with your custom browser?


#5

sorry for delay i m not in office for some time but i will try it when i get back, sometime in next few days…


#6

I just test it and now again everything work fine, thanks for fix…


#7