Can't log in with Twitter in my native iOS app

fabric
login
twitterkit

#1

Hi there, I’m trying to log in my app users via Twitter. In simulator I’m able to log in (and request user email address) but when I try in a physical device I got:

Optional(Error Domain=TwitterAPIErrorDomain Code=89 "Request failed: unauthorized (401)" UserInfo={NSLocalizedFailureReason=Twitter API error : Invalid or expired token. (code 89), NSLocalizedDescription=Request failed: unauthorized (401), NSErrorFailingURLKey=https://api.twitter.com/1.1/account/verify_credentials.json?include_email=true&skip_status=true, TWTRNetworkingStatusCode=401})

Ps. I already request for Fabric permissions.

Using Xcode 8.1 and trying with iOS 10.1.0

Please, can anybody helpme?


#2

Hey @alejandrolagosr,

If you log out of your iOS app and then back in, does that do the trick or change the error you see?

-Mike


#3

Thanks you for your response @bonnell,

I tried that way but I got the same error, I’m only able to log in with simulator.

-Alejandro


#4

Hmm, thanks for confirming. Can you email into support(at)fabric(dot)io with your Twitter Consumer key and reference this thread?

-Mike