Can't get site to validate - even with Twitter metadata and trailing slash


#1

I can’t seem to get the Twitter Card to validate on http://poweredbyfacts.com - the metadata’s been added correctly, it appears, via “All-in-One-SEO” plugin (wordpress), and scan of the page source code. Just keep getting “ERROR: Fetching the page failed because the request timed out.” - though one time, when using “http://www.poweredbyfacts.com”, it seemed to recognized the metadata, then the redirect, and then a “not whitelisted” message…but only once, never again. The site performance is OK.

WITH a trailing slash (http://poweredbyfacts.com/) I get:

INFO: Page fetched successfully
INFO: 8 metatags were found
WARN: Not whitelisted

But still can’t render the card preview.

Any thoughts?


#2

Hi,

no pro here but maybe the twitter bot is blocked ? I have seen issues like that.

Good luck :slightly_smiling:


#3

Your site’s robots.txt file is blocking access to the image. You need to fix this, and then you should see the image show up in the card. I successfully used http://www.poweredbyfacts.com/ (with the trailing slash) in the validator so this otherwise looks good.


#4

Thanks for checking - I updated the image path - but it still doesn’t render a preview for me. You saw it render a good preview, using https://cards-dev.twitter.com/validator ?


#5

Update - the Twitter Card seems to work, in Twitter (but only with a full URL, not using bit.ly)…but the validator still doesn’t. Oh well.


#6

Working here


#7

@andypiper Could you please take a look at my situation and let me know how what I might need to change? My card was whitelisted when we were using a Heroku domain but now that we switched to our own domain it no longer is validated and I am not able to figure out the issue.

INFO: Page fetched successfully
INFO: 14 metatags were found
WARN: Not whitelisted

Thanks Andy.


#8

There’s no twitter:card type tag specified, which is the critical issue as this means the validator doesn’t know what it is supposed to validate.

You’ve combined the og:property and some of the other twitter: tags, which means that the crawler cannot see the values. Try having twitter:title etc as separate meta tags with their own values.

See our troubleshooting FAQ post for more things you can check for yourself.