Can't get past this: valid Twitter Kit URL Scheme set up in the app settings

api

#1

Just to add to this nightmare…
I’m read the spots of most of the posts here. And swear that I have followed it all correctly.

> info.plist
> <key>CFBundleURLTypes</key>
> 	<array>
>         <dict>
>             <key>CFBundleTypeRole</key>
>             <string>Editor</string>
>             <key>CFBundleURLSchemes</key>
>             <array>
>                 <string>twitterkit-123456789</string>
>             </array>
>         </dict>
>             <dict>
>             <key>CFBundleTypeRole</key>
>             <string>Editor</string>
> 			<key>CFBundleURLSchemes</key>
> 			<array>
> 				<string>fb123456789</string>
>             </array>
>             </dict>
> 	</array>

I have TwitterKit pod/frameworks installed

My simple piece of code is this.

- (IBAction)postToTwitter:(id)sender {
    if ([SLComposeViewController isAvailableForServiceType:SLServiceTypeTwitter]) @autoreleasepool {
    
    {
        // This used to just work - now after 11, it doesn't
        SLComposeViewController *tweetSheet = [SLComposeViewController
                                               composeViewControllerForServiceType:SLServiceTypeTwitter];
        NSString *twitterText =  [NSString stringWithFormat:@"%@%@", @"Just sent my location. Please check! ..", linkText];
        [tweetSheet setInitialText:twitterText];
        [self presentViewController:tweetSheet animated:YES completion:nil];
    }
    UIGraphicsEndImageContext();
// So I added this to try and login
    } else {
    TWTRLogInButton *logInButton = [TWTRLogInButton buttonWithLogInCompletion:^(TWTRSession *session, NSError *error) {
        if (session) {
            NSLog(@"signed in as %@", [session userName]);
        } else {
            NSLog(@"error: %@", [error localizedDescription]);
        }
    }];
    logInButton.center = self.view.center;
    [self.view addSubview:logInButton];
    NSLog(@"Service Type: %s", "Not Available");
    }

Interestingly enough, it pops a huge LOGIN button onto the face of the app, but when I click the Login Button I get the usual error message
*** Terminating app due to uncaught exception ‘TWTRInvalidInitializationException’, reason: ‘Attempt made to Log in or Like a Tweet without a valid Twitter Kit URL Scheme set up in the app settings. Please see https://dev.twitter.com/twitterkit/ios/installation for more info.’
*** First throw call stack:

So really - any help or pointers would be nice. Thanks