Can't get cards to work

cards

#1

Description of issue: Can’t get cards to work. Image does not show up … “share” does not appear to render as a card at all.

URL affected (must be public): https://sites.photographerflashwebsites.com/products/product/maseratis/maserati-d

Troubleshooting steps attempted [note that we will not prioritise posts unless there is evidence of following the troubleshooting guides]:

  • tried using twitter tags, tried using og tags
  • tried editing robots.txt (tried a bunch of different settings)
  • tried using curl while specifying -A Twitterbot (appears to be getting blocked even with completely blank robots.txt)

Just no clue how to get this to work as expected.

As a final question, and not trying to be rude with this, but with all these extra complications (robots.txt being configured correctly, having to use twitter vs. og meta tags, caching of robots.txt, can’t read meta tags dynamically loaded via javascript, can’t read sites on localhost, etc., etc., etc.), why don’t Twitter and other social networks simply give developers a url to post to?:

https://twitter.com/share.php?image=https://site.com/images/my-image.jpg&title=My%20title%20goes%20here&description=my%20description%20is%20really%20awesome.

Wouldn’t that be so much easier?


#2

It’s the fact that the user-agent is being blocked that is the issue here. I don’t know why that would be - you might need to check the webserver configuration.


#3

Thank you for the response Andy. As I described in my original message, I have completely emptied robots.txt (totally blank file), and yet the Twitterbot agent still appears to be getting blocked. Any idea what I would check next to prevent the Twitterbot from being blocked?


#4

I really am not sure, as I’ve not seen an error message like that before. Also, it doesn’t make a lot of sense, since the server returns HTTP 200 OK, and then apparently seems to serve a blank page about the same size as the actual page, appended with the “blocked userAgent” message. I can only assume there’s something in the web server config that’s doing this - I’m not familiar with openResty though.


closed #5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.