Can't find meta tags when using custom domain on heroku


#1

Hey all,

I have a simple site up on heroku and I’m trying to get twitter cards working for our press release articles. I’m pretty sure I have everything set up properly because if I use my base heroku URL in the validator (https://sequencebio.herokuapp.com/press/release/2016-08-10) the card shows perfectly fine. However, if I use our actual custom domain (https://sequencebio.com/press/release/2016-08-10) it says it fetched the page successfully, but can’t find any meta tags.

I’ve read through at least a dozen threads on here and tried all of the recommendations, but no success - I’ve hit a wall.

Also, fwiw, the Facebook sharing debugger tool can find the og tags just fine on https://sequencebio.com/press/release/2016-08-10

Hope someone can shed some light on the situation. Thanks in advance!


#2

Weird - must have been a glitch, because it seems to be working OK here for me now?


#3

Haha well great - it’s working for me too! So strange…


#4

So weird, I just posted a new press release about an hour ago and I’m having the same issue - so the problem isn’t solved unfortunately :frowning:

Here’s the new page: https://sequencebio.com/press/release/2016-08-22

Again, if I use the .herokuapp.com domain, it’s fine.

Seems like there’s a big delay between the page going live and twitter finding the meta tags - maybe some sort of caching setting I’m unaware of? (the link I had in my original post was put online yesterday, and only started working a couple hours ago).


#5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.