Can't create new app - "email not confirmed" error


#1

I’ve been trying to create a new app for weeks now but I just get an error message saying my email address has not been confirmed but it has. I’ve also created apps in the past using that account with no problems at all.

I have done a lot of searching around the matter and it seems it’s a known bug that can be resolved by updating your Twitter account’s email address and then changing it back. I have tried this, but when I click the link to confirm my new email address, every time I go back to my Twitter account it still displays the old address in the Settings and I am still unable to create a new app.

I’ve also followed Twitter’s request to contact their support team. Although the contact details and instructions are on the page, following them just seems to instantly trigger an email saying that I contacted the wrong place and just sends me a link to the (completely useless) support articles.

I’ve also posted on an older thread here where someone was having the same issue, but there was no response.

Please help, this is driving me nuts!


#2

Hi @madebyjenni - I’m really sorry you’re hitting this issue.

Can you confirm that you’re using the account you’re posting here as, or is there another account you’ve been using to register your apps?

When you contacted support, did you use the Platform Support forms? https://support.twitter.com/forms/platform - you could try the final option on that page.


#3

Thanks Andy, it’s this account.

After emailing again I got an obviously human reply from support@twitter.com outlining the steps to change and confirm my email address, which I’ve already tried before as per my post above. After explaining this to them in my latest email reply, I instantly got an email back saying ‘Twitter does not monitor emails to this address’ - which is clearly not true.

This is getting so frustrating :frowning:


#4

Okay, after asking for help from a dev I know, I finally managed to get it to update my email address. The email address I was trying to update it to just wasn’t liked by the Twitter backend for some reason (no idea why, and no helpful error messages of course, just the inaccurate confirmation that it had been changed). I tried another email address and it updated fine.


#5

Really sorry for the annoyance! I’m glad to hear you got things working though.