Can't change my callback url


#1

I’ve changed my Callback Url for my app but twitter continues to redirect to the old callback url even though the settings page is showing the updated url. I’ve even deleted the app and recreated it and it’s still doing this. I set this yesterday and it’s still doing it today. I’ve tried different browsers and private browsing and that also hasn’t done it. Any advice?


#2

If you set the oAuth callback URL explicitly in your code by doing something like the following

$OAUTH_CALLBACK='[Callback_URL]';

where [Callback_URL] is your callback URL, then either do not explicitly assign one as oAuth 2.0 allows for this I believe, or just fix it to the right URL. I was having the exactly the same problem. Even though you changed your callback URL on Twitter, if you’re explicitly assigning a callback URL in your code, it’ll override whatever URL you set on Twitter.


#3

Even I experience the same problem -
I’ve changed my Callback Url for my app but twitter continues to redirect to the old callback url even though the settings page is showing the updated url. I set this yesterday and it’s still doing it today. I’ve tried different browsers and private browsing and that also hasn’t done it. Any advice?