Can't add members to a list (Code 104)


#1

I’ve been having issues adding members to a list using either “lists/members/create_all” or “lists/members/create”.

It’s basically a small app witch takes an array of ID’s and adds to a list belonging to the authorised user.
It’ll take the array and break into chunks of 50 and submit to “/create_all”. If the expected return doesn’t match then it’ll try again before taking that same list and submitting individually to “/create” to exclude any accounts that are blocked or don’t exist.

After a couple of submissions the “/create_all” returns:

404 {"errors":[{"message":"Sorry, that page does not exist","code":34}]}

And the submissions to “/create” return:

403 {"errors"[{'message':"You aren't allowed to add members to this list","code": 104}]}

The list belongs to the authorising user, the list is nowhere near full and none of the members being added have blocked the authorising account.

What’s also interesting, is that after these messages appear, the authorising account can’t even add members via Twitter.com.

Is there some kind of internal and unpublished rate limit being hit? Surely not with less than 80 members. Am I submitting too quickly (i.e. being reported for hammering the system). I do repeat the above tasks because of the lack of meaningful responses (I found that submitting a list to /create_all might add 47 members one moment and 50 another).

Does anyone have any idea what might be going on and perhaps a solution/workaround to effectively submit members without triggering a temporary block (assuming that’s what’s going on).

Many thanks

Justin


#2

Did you get anywhere with this? I am seeing the same.
Trying to add members to a list I created. The list is initially empty. After adding 27 members, I get this same error.


#3

This seems like a “claytons API limit”. Well actually, it’s not limited to the API.

Basically if you make a list and add folks to it, either manually or through the API, you can’t get very far before you hit this error. Then you have to wait a while (15 mins?) and come back.

Now I wouldn’t have a problem with this, if only it were actually enumerated in
/application/rate_limit_status with resources=“lists”… But it’s not and that’s proving quite painful :frowning:

I can’t play nice with the API and check how many of these I have left, waiting until more are available. No. Instead I have to plow face-first into the limit, then back off for a while and hope like crazy that I don’t get blacklisted.

Please, please Twitter dev team. Help us out here!


#4

Read operation API limits are reported in rate_limit_status (and in the rate limit header on the response from an API call); but the posting / update limits are not. This is because these values are adaptive and may vary at times of high traffic, or if the system suspects that something suspicious is going on.

15 minutes is the standard rate limit window for most operations on the Twitter API.


#5

Thanks for the prompt response @andypiper !

I appreciate that limits may be adaptive. Mind you such a low rate on adding folks who follow you to a private list seems a bit strange, but I figure you folks must have a good reason I don’t quite appreciate.

I guess the upshot for me is I wish I had a way of know the limit before I hit it, so I can back off before then. I don’t really like running into the limits - if everyone avoided hitting them in the first place there’d be less load on Twitter, right?

Right now I am repeatedly hitting it, trying to code a way that’s not going to hit the limits aggressively. Hopefully I don’t get blacklisted :frowning:


#6

And now I am 403 on /lists/members/create and presumably other write operations… But not on reads.

All from trying to actually get X-Rate-Limit-Reset from PTT *sigh*

*starts beating head against wall*


#7

Anyone figured this out?

I’m having the same issue… still not clear how lists/members/create_all is rate limited.

Thanks for any tips.


#8

Yep, I also ran into either a limit with using the create_all API or some other problem or bug. I was successfully able to add 900 users by user_id in 100 user POST Requests and then things went south and I was only allowed to add 1-4 new additional users. I tried removing possible user_ids that could be causing the script to stall or stop and that did not work either. So it did not appear to be a scenario like array of user_ids: user_id X not allowed because of X. Now I am also unable to add users to lists by using the Twitter GUI. Oh well Lists really seemed like the optimum way to go instead of doing things 1zs 2zs. but obviously Lists are not really user friendly via the API. All GET Requests API code works flawlessly.


#9

Aha I have confirmed that the Twitter Limit for adding people to any/all Lists is 1,000 per day or 12 hour period. After waiting a day the Twitter GUI allowed me to add new people to Lists. I manually added 1,000 one by one and then hit the Limit at 1,000 and saw the “Your account may not be allowed to perform this action. Please refresh the page and try again.” Twitter Limit error notification.


#10

Thanks for figuring this out and posting! I was stumped.

UPDATE: So the first time I worked with adding users to a list I added about 1,300 within a few minutes before that activity was suspended for the account. Account was fine for everything else, just couldn’t add users to lists. But the account wasn’t allowed to add users to list for about 24 hours. This may be because it added 1,300 before being disabled, so the first 1,000 disabled it for 12 hrs and the next 300 disabled it for another 12 hours.

Just don’t be surprised if the functionality is disabled for 24 hours.