Cannot get website whitelisted for twitter cards


#1

For a long time on our Philips websites, we have had twitter cards on our pages for summary_image and a couple of weeks ago we changed this to summary_image_large

When trying to tweet a URL of our Philips.com website, it does not show any twitter card anymore, so I tried to use the validator to see what could be the issue. While I know the whitelist could be a false positive, I tried to resubmit a new whitelist authorization with the following URL:

I received back an email that the URL was not accessible, however based on the troubleshooting steps we could not see why not.

  1. The user-agent Twitterbot is not blocked by https://www.philips.com/robots.txt

  2. We saw that during my validation of the URL, the TwitterBot was able to retrieve the URL and got a 200 response
    199.16.157.180 - - [08/Nov/2017:08:46:10 +0000] “GET /www.philips.com/a-w/innovationandyou/article/extended-story/a-little-more-action.html HTTP/1.1” 200 20142 “-” “Twitterbot/1.0” “-” “1072_27393||”

  3. When loading the page with Javascript disabled, the meta-tags are still appearing in the page

  4. We also saw no requests coming in from the IP range as specified (199.59.156.* or 199.59.148.*)

Does someone have an idea what we would have to check as well on top of our investigation to get our website whitelisted (again) for using the summary_large_image twitter cards?


#2

Your content contains:

<meta property="twitter:card" content="summary_image_large">

It’s easy to miss this, but the correct tag should be “summary_large_image” - you have it the other way around.


#3

Okay, now I feel really stupid that I did not see this before @andypiper. Also perhaps strange the developer did not verify the correct values via the documentation, but in any case I now know what at least we need to fix and afterwards check if we should actually need validation/whitelisting or not.

Thanks for this, sometimes you look and look but never find as you have been looking at it for too long.


#4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.