Cannot add phone number to twitter account


#1

I need to create an api but twitter do not accept the phone number I am providing. It’s been 2 days and nothing. I dont know how these people operate but no one to contact, no phone number, customer service etc. The message I get is
We are unable to register your phone number now. Please try again.


#2

Sorry you are having troubles, you can contact the Twitter Support in order to add Apps without a phone number, if you are unable to add it, see below:


Does not allow me to create a new app
#3

Thanks very much for the response. I have contacted support via the form you gave me. Hope to hear from them soon.


#4

I am afraid, no response from Twitter what so ever. Nothing works and no customer support. Perhaps I am non-paying user so I am not of any use to Twitter.


#5

Tried contacting them but no reply.


#6

Try dropping the leading zero in your number so instead of typing “055 5555” just supply “55 5555”. It worked for me


#7

Had exactly the same issue. @chriswaucks hint worked :wink:


#8

The advise here sends you in an eternal loop. You will go to Forms/Platform to only find that the question is not an option and they will direct you back here to search for others having similar problems. I bring it up here because here is where it happened to my previous response. Why is the community flagging messages that challenge the value of the solution offered? Shouldn’t readers see real-world frustration where it exists to know that they are not alone? A longer message, expressing more frustration, but not with all caps like I used, from RettungBS was also flagged and hidden. Honestly, I appreciate the community here and hope we can all thrive with this great software.


#10

Hi, I’m from Argentina. Trying to register my application, the SMS with the verification code never arrived. The page said something like "Check your mobile phone! An SMS have been sent … Any idea? Thank!


#11

I have the same problem… Trying to add my phone number and it is impossible. Twitter says me to try again. Is what someone found a solution?


#12

You’ll need to open a ticket via http://support.twitter.com/forms/platform requesting help with this. Thanks.


#13