Can not archive TwitterKit with Bitcode enabled in Xcode 8.3


#1

Currently using Cocoapods to integrate TwitterKit. I’m currently attempting to archive use Xcode 8.3.3.

When using the latest TwitterKit, 3.2.0, Xcode archive is failing during the link phase with the following error: "
Showing Recent Messages
ld: bitcode bundle could not be generated because ‘/…/Pods/TwitterKit/iOS/TwitterKit.framework/TwitterKit’ was built without full bitcode. All frameworks and dylibs for bitcode must be generated from Xcode Archive or Install build for architecture arm64

When downgrading to TwitterKit 3.0.2, I get the following error: “
Showing Recent Messages
-[TWTRWebAuthenticationViewController initWithAuthenticationToken:authConfig:APIServiceConfig:hasExistingSession:] in TwitterKit(TWTRWebAuthenticationViewController.o)
Symbol(s) not found for architecture arm64”

Other versions of TwitterKit between 3.0.2 and 3.2.0 also fail for similar reasons. I have also tried removing TwitterKit from my Podfile and manually integrating the frameworks. However that is met with Bitcode version mismatch errors (I assume the newest TwitterKit has been compiled with Xcode 9 tools) and older versions fail for vague Bitcode reasons as well.

I do also have Fabric in my Podfile (version 1.7.0) but I have not enabledTwitterKit integration in my info.plist and perform the initialization manually.

For business reasons, I must compile with bitcode enabled and am looking for any suggestions on how to fix this.


#2

Please refer to this post for solution: TwitterKit' was built without full bitcode TLDR; use version 3.1.1

The Bitcode version mismatch was from another Pod in my Podfile. Apologies for the red-herring. I consider this post solved.


#3