Callback URL not approved


#1

Salve, non riesco a collegare la mia App con wordpress, tramite il plugin revive old post, mi da questo errore: Error connecting twitter {“errors”:[{“code”:415,“message”:“Callback URL not approved for this client application. Approved callback URLs can be adjusted in your application settings”}]}


#2

Per the announcement, you need to set the correct callback URL for your application on apps.twitter.com


#3

It still wont work, This is our callback url as
https://axp-cust220.dev.sapbydesign.com/sap/byd/oauth/twitter/?state=00163E5FA5D51EE8A2A99A0

We have tried all part of the domain in setting of apps.
like
https://sapbydesign.com
https://sapbydesign.com/auth/twitter/callback
https//axp-cust220.dev.sapbydesign.com
https//dev.sapbydesign.com

none of them works.

What should we do about the call back URL or what is the correct call url in our case,
Thanks, Tom.


#4

The callback URL needs to be the full URL without any query parameters.

https://axp-cust220.dev.sapbydesign.com/sap/byd/oauth/twitter/

#5

Thanks, It works now. However, is it possible to allow wild card domain name like https://.sapbydesign.com or https://.dev.sapbydesign.com to work? We have lots of system and tenants to access Twitter pages so it is technically not possible to define every callback URL and I think it will also run out of your maximum allowable callback URL. Thanks, Tom.


#6

Wildcards are not supported. The recommended approach is to have https://auth.sapbydesign.com/auth/twitter/callback or similar and then when you generate the initial request_token store the subdomain they should return to in your state value.


#7

Whenever I tried to add my Twitter account/feeds to my email I am getting this error, though it was fine until recently when I removed some of apps from Twitter settings. Kindly help.

Bad Request

The associated OAuth provider denied the request: ‘<?xml version=“1.0” encoding=“UTF-8”?><errors><error code=“415”>Callback URL not approved for this client application. Approved callback URLs can be adjusted in your application settings</error></errors>’.


#8

@RealEstateSA_PK - I addressed your question in your other topic.

Please do not post duplicate content.