Callback URL not approved - but worked for months

callback

#1

Hi,
have there been any changes to the API recently? All of sudden my app stopped working due to well known problem:

code=415 Callback URL not approved for this client application. Approved callback URLs can be adjusted in your application settings_

I checked my callback url in app settings. There is a valid address I used for months befeore and it worked.
I would appreciate any help.


#2

Yes, there was an announcement a month ago about this:

The URL must match the callback URL exactly, in the past this was not checked


#3

Thanks @Connexinet,
@paweljarosz83
We’ve been making many changes and have posted our overall roadmap here Please review our announcement from May here, here and here.

You can fix this error very simply, by whitelisting all of your callback URLs in your app settings on apps.twitter.com.


#4

I’m sorry, but I whitelisted my call back URLs in my app settings. I am using Auth0 for authentification and I’m still getting the message that access is denied because the call back URL is not approved.


#5

I have added all the possible callbacks as whitelist in app settings but i am still getting the same error. Please help


#6

I get the error code:
[TwitterKit] did encounter error with message “Error obtaining user auth token.”: Error Domain=TWTRLogInErrorDomain Code=-1 “” UserInfo={NSLocalizedDescription=}


#7

Where is the ‘whitelist’ section exactly? In the Settings tab there’s Callback URLs section with input fields. It this what we talk about? If so, I have first one filled with https://twitter.com


#8

I did not use the callback url. I typed https://www.google.com in the callback url. This is a usage posted on the twitter-kit-unity site.

I developed the unity app and logged into twitter with the twitter-kit-unity plugin. So far, it worked fine.

Is there any problem with entering callback url anything? I do not know which callback url to use. I do not have a callback url. Do I have to make this?

Please provide detailed manuals. This process is difficult for users who simply use the Twitter SDK.


OAuth still returns 403 (error 415) even when callback urls are set
#9

The whitelisted callback URL cannot be https://localhost


Callback URL
#11

For iOS

Register the XCode URL Schemes value in the Callback URL.
The URL Schemes value is followed by ://.
ex) twitterkit-jofpqujfoiwjfownfewojfiewfwe://

I succeeded in logging in to iOS.

What about Android? I tried it the same way, but it does not work.

<intent-filter>
<data android: scheme = "twitterKey-jofpqujfoiwjfownfewojfiewfwe" />
</intent-filter>

What is the problem?


#12

Hi!

We call the twitter api from more than 15 differents domains.

Before 12th june we use dynamic callback whithout any problem.

Now, on the Api setting we can add to whiltelist max of 10 URL.

Any solution for this?

Thank in advance!


#13

I have the same problem. I receive the following error from my application log: ’ Callback URL not approved for this client application. Approved callback URLs can be adjusted in your application settings </ error> </ errors> ’

In my case if I have the application configured as follows:

Callback URL https://www.aguasandinas.cl/web/aguasandinas/c/portal/twitter_login

Callback URL Locked No

Sign in with Twitter Yes

App-only authentication https://api.twitter.com/oauth2/token

Request token URL https://api.twitter.com/oauth/request_token

Authorize URL https://api.twitter.com/oauth/authorize

Access token URL https://api.twitter.com/oauth/access_token

Even so, I’m still receiving the error.

Where is the white list? I understand that putting the URL in the CALLBACK URL section would solve the problem … but no. Could you help me?


#14

Try adding callback url twittersdk://
It worked for me.


#15

Hi @dev1showmb What is your use case for using 15 domains in the same app?


#16

I am facing the same issue. I have a php script that is being used on multiple domains by multiple users which was working fine until this change.


#17

I’m using the swifter library (https://github.com/mattdonnelly/Swifter) and I’m now facing the same issue. I updated the callback URLs and added the same url callbacks to the URL Schemes in my Xcode Info.plist (minus ://) but I’m still get an error on Auth? The callback documentation says the following?

Please note: Mobile apps with app-specific protocols must use just the protocol. For example, please use example:// as opposed to example://authorize. Any deep linking will result in the following error:


#18

What is the whitelist, and how does one add a URL to this? I’m using the rtweet package in R to get tweets using a few different hashtags, for practicing text analysis and for comparing, say, this week’s wordcloud with last week’s, etc, so nothing particularly advanced, but the create_token() function isn’t working, and it seems it’s the recent changes to the OAuth thing. I’m a bit basic when it comes to all of this, and would appreciate any assistance.


#19

I’m using Java with Spring Social Twitter. I first thought it could be a framework problem, but now I see many guys from other technologies facing the same problem…


#20

Same problem here. We use dynamic urls for callback. We are currently working on a work around for this issue so we make a callback url in our website then registered the url to apps.twitter.com as callback. We used https://github.com/abraham/twitteroauth for twitter login.

on the code we added the callback url for the oauth_callback parameter but the problem still persist.


#21

Hi @happycamper
In order to get best local SEO position we launch our project with different domains, one per country where we want to be.
Really we use more then 15 domains, around 40.
Our Twitter app is the same for all domains, and before 12th june we could use dynamic Callback without any problem.
Any solution for this issue?
Thank in advance!