Building a Twitter Application using C++ & Marmalade


Hi All,

I am currently completing a MSc in Digital Media and for my final thesis I’m building a Twitter Application. If I am posting in the wrong part of the forum I humbly apologise.

I have been using Marmalade to do this, however I am struggling with the code. For some reason I’m not actually able to connect to Twitter. :frowning:

I’m going to post some snippets below - if there is anything that anyone can recommend - I would really appreciate it :slight_smile:

I have tried the following combinations and still get the same error;

PC running Windows 7 Enterprise Marmalade 7.7 with VS2010 Express, Marmalade 7.7 with VS2013 (Community Version) Marmalade 7.8 with VS2010 Express, Marmalade 7.8 with VS2013 (Community Version)

PC running Windows 8 Marmalade 7.8 with VS2010 Express

I would really appreciate any support / suggestions that you can offer me - I’m completely stumped and need to fix this issue :frowning:

Thank you for your time,



Hi Ste, thanks for this post. Interesting stuff! I’m actually having quite an adventure here as I hadn’t heard of Marmalade and I’ve never tried this Twitter support, so I downloaded the SDK but I’m having issues getting the samples to compile on my Mac! :crying_cat_face:

So in the absence of being able to debug this myself directly, let’s take a step back.

Looking at the error trace you’ve posted above, it looks like network socket code that is having issues. One thing that springs to mind is that we disabled insecure SSL versions a few months ago, so I wonder whether the Marmalade libraries support the current (TLS) connection.

I did some digging and found that the IwTwitter stuff is built on twitcurl. I wonder if that uses the latest secure connection? I can’t find references to inside my Marmalade SDK so I’m not quite sure if this is somehow built into the runtime as a binary.


Actually I’ve now found the bits of the Marmalade SDK which could be causing this - openssl, curl and twitcurl. I know that twitcurl itself works fine, or it did the last time I compiled it, albeit a modern version of openssl (1.0.2d here).

It looks like the openssl version Marmalade ships with is 1.0.0g - I wonder whether this is forcing a TLS connection by default? I am finding it tricky to recompile the various third party pieces as well as have an example work, but I’ve definitely been able to reproduce what you’re seeing. My suspicion is that this could be the cause, but I’m not ruling out an issue on the Twitter side. Have you contacted the Marmalade folks as well?


Hi Andy,

Thank you so much for the suggestions.

I have found out from my colleague who is also working on the project that we have actually already contacted Marmalade - sadly they don’t seem to responsive to the issue. :frowning:

I’m not really sure how to proceed, we have literally tried everything including the Se3 socket,

If you or anyone has any further suggestions I’d greatly appreciate it,