[BUG] Twitter Kit iOS 3.0.4 login sometimes fails to redirect back to host app

auth
ios

#23

What do you mean by Twitterkit ina framework? I am having the same exact issue. It’s always returning false, i’ve checked the url and it seems correct, options are proper too. Did u manage to solve the issue ?


#24

Any updates Rajul?


#25

Hi Rajul,

Any updates on the issue? It seems reproducible with TwitterKit v3.2.1 and Twitter app v7.10 on iOS 9.3.5.

Thanks!


#26

Unfortunately we are still waiting for a fix on the Twitter iOS App, which will fix the issue


Twitter app not redirecting back to my app after successful login
#27

It works on Twitter Kit 3.2.1.
Could any one try it again?


#28

Will the update fix this problem also?


#29

I have Twitter Kit version 3.2.1 with twitter App 7.11.
My app calls the Twitter app but I never receive a call back.


#30

Sorry for late reply, yes I managed to solve the issue. It was a link issue, needed to make sure to have the twitterkit linked to the app and not to the framework.


#31

Hi

It fails to redirect back to host app on TwitterKit (3.2.2).
I click Authorize app button and I see some progress.
Final it is still on Authorize page.

  • TwitterCore (3.0.3)
  • TwitterKit (3.2.2)

By the way, it worked on TwitterKit (3.2.1).


#32

Not getting it work. Please need some more brief


#33

TwitterKit 3.3.0 redirect back failed.

Mobile : iPhone 8
iOS Version : 11.2
XCode Version : 9.2
Twitter Kit : TwitterCore (3.1.0)
TwitterKit (3.3.0)


#34

Hi Team,
Still the issue persists. Do we have any alternate way to fix this issue to way back to the App from Twitter app or we need to wait a fix from Twitter Team.


#35

It is an issue in the Twitter App. I’m trying to reproduce this issue more consistently and I noticed that the issue is very consistent if the Twitter account has 2FA enabled. Has anyone else noticed this?