Basic authentication with Postman failed - code 215/ code 32


#1

Trying to learn the API has been hard and I have not been able to get even a simple request to work.

I have gone to back to basics and I am trying to simply make a request that does not fail. I filled in the appropriate info, at least I think I did, but don’t know how to debug this. The only msg in the ‘console’ is the error displayed here.

I copied the keys and tokens exactly as they were from the dev portal.

Any help would be appreciated!


#2

Hi @chris_del - I’m sorry that getting started with our APIs has been challenging.

What information do you have in the Advanced section, below the access keys and tokens section? Make sure that Timestamp, Nonce and Realm have no values - like this:

Let me know if this helps?


#3

Hi Aurelia,
Thanks for the response. I’ve left the advanced section blank and it looks identical to yours.

I’ve just filled in the four keys like the screen shot and hit submit and hope that it worked. But I still get the 215 error.

Is it generally possible to access twitter this way? Not sure what I am missing.


#4

@Aurelia Just checking in as I have not fixed this.

I abandoned Postman and made a server. I’m using the twitter NPM. I copied the code from the page and it comes back as
ERROR [ { code: 32, message: 'Could not authenticate you.' } ]

var Twitter = require('twitter');
 
const client = new Twitter({
	consumer_key: process.env.CONSUMER_KEY,
	consumer_secret: process.env.CONSUMER_SECRET,
	access_token_key: process.env.ACCESS_TOKEN_KEY,
	access_token_secret: process.env.ACCESS_TOKEN_SECRET
})
 
var params = {screen_name: 'nodejs'};
client.get('statuses/user_timeline', params, function(error, tweets, response) {
  if (!error) {
    console.log(tweets);
  }
});

I triple checked my credentials and they match and are not null or undefined. What am I doing wrong?


#5

Okay false alarm. Sorry.

One of the keys was wrong…blarg. AND, it does not seem to accept relative paths so the above URL is not valid. Authentication issue seems to be solved. Thanks


#6